Problème ping

Résolu
cpetter Messages postés 38 Date d'inscription vendredi 7 mai 2004 Statut Membre Dernière intervention 4 octobre 2007 - 1 févr. 2005 à 00:01
cs_coq Messages postés 6351 Date d'inscription samedi 1 juin 2002 Statut Membre Dernière intervention 2 août 2014 - 15 févr. 2006 à 16:53
Hello





Je suis en train de faire mumuse avec les demande ping, netstat, ... et
j'ai trouvé une explication pour ce genre de requete sur ce site.


http://www.csharpfr.com/forum.v2.aspx?ID=111352


Mais quand je met ce code





Process p = new Process();


p.StartInfo.CreateNoWindow = true;


p.StartInfo.FileName = "ping www.scripts-web.net";


p.StartInfo.UseShellExecute = false;


p.StartInfo.RedirectStandardOutput = true;


p.Start();


string sortieConsolePing = p.StandardOutput.ReadToEnd();


MessageBox.Show(sortieConsolePing);





J'ai l'erreur suivante


Le fichier spécifié est introuvable





Par contre si à la place de "ping www.scripts-web.net", je met "ping"


il m'affiche le retour de la commande ping sans rien derrière!!!





je comprend vraiment pas!!





plz help!!
A voir également:

3 réponses

cs_coq Messages postés 6351 Date d'inscription samedi 1 juin 2002 Statut Membre Dernière intervention 2 août 2014 100
1 févr. 2005 à 10:45
Process p = new Process();
p.StartInfo.CreateNoWindow = true;
p.StartInfo.FileName = "ping.exe";
p.Arguments = " www.scripts-web.net";
p.StartInfo.UseShellExecute = false;
p.StartInfo.RedirectStandardOutput = true;
p.Start();
string sortieConsolePing = p.StandardOutput.ReadToEnd();
MessageBox.Show(sortieConsolePing);

il me semble.

Cocoricoooooooo !!!!
coq
MVP Visual C#
3
cpetter Messages postés 38 Date d'inscription vendredi 7 mai 2004 Statut Membre Dernière intervention 4 octobre 2007
1 févr. 2005 à 12:09
Merci beaucoup!!



super cool!!
0
cs_coq Messages postés 6351 Date d'inscription samedi 1 juin 2002 Statut Membre Dernière intervention 2 août 2014 100
15 févr. 2006 à 16:53
On vient de me signaler une erreur dans mon code ci dessous :

La ligne
p.Arguments = " www.scripts-web.net";
devait bien sûr être
p.StartInfo.Arguments = " www.scripts-web.net";

/*
coq
MVP Visual C#
*/
0