Formule dans une chaine [Résolu]

Signaler
Messages postés
17
Date d'inscription
mardi 2 mars 2010
Statut
Membre
Dernière intervention
30 mars 2010
-
Messages postés
17
Date d'inscription
mardi 2 mars 2010
Statut
Membre
Dernière intervention
30 mars 2010
-
Bonjour,
Voici encore un probleme pour moi, je dois entrer une formile dans une feuille excel sacahnt que cette formule est établi a partir d'une bouble FOR dont voici le code:

Dim j As Integer
For j = 2 To nb_articles + 1
Feuil2.Cells(j, 18).FormulaLocal = "=RECHERCHEV(Qj;Ilot!$A:$C;2;FAUX)"
Next j

Bien sur la formule de toute les cellule contient "Qj" et non Q2,Q3,Q4... etc

Merci d'avance

2 réponses

Messages postés
797
Date d'inscription
mardi 7 juin 2005
Statut
Membre
Dernière intervention
23 février 2011
5
Ton j est déclaré en tant que partie intégrante de ta formule. Il faut transformer pour obtenir quelque chose de ce genre :

Feuil2.Cells(j, 18).FormulaLocal = "=RECHERCHEV(Q" & j & ";Ilot!$A:$C;2;FAUX)"

Molenn
Messages postés
17
Date d'inscription
mardi 2 mars 2010
Statut
Membre
Dernière intervention
30 mars 2010

Merci, je me doutais qu'il y avait une solution de ce genre moi j'écrivais comme ca : Feuil2.Cells(j, 18).FormulaLocal = "=RECHERCHEV(Q" j ";Ilot!$A:$C;2;FAUX)" mais j'avais une message d'erreur...
Merci beaucoup en tout cas.