Probleme VB.net

sultan27 Messages postés 1 Date d'inscription mercredi 26 avril 2006 Statut Membre Dernière intervention 16 novembre 2009 - 16 nov. 2009 à 13:10
PCPT Messages postés 13280 Date d'inscription lundi 13 décembre 2004 Statut Membre Dernière intervention 3 février 2018 - 16 nov. 2009 à 16:20
bonjour, j'ai un problème en vb.net.
quand je veux passer du code vers la form (mode design), l'application se ferme automatiquement, et ceci valable pour toutes les forms.

merci de m'avoir aider à résoudre ce problème

6 réponses

cboulas Messages postés 2641 Date d'inscription mercredi 2 juin 2004 Statut Membre Dernière intervention 8 janvier 2014 16
16 nov. 2009 à 13:48
Salut, tu n'a pas un message d'erreur ou un truc de ce genre ?
A moins d'avoir un bug, normalement il y a un message qui doit s'afficher ou alros il s'agit d'un virus , ou peut-être ALT-F4 est rester bloqué

Chris...
__________________________________________________________________________
- La vérité n'est pas ailleurs, elle est sous le nez de chacun, quelques mouvements neuronale permettent de l'entrevoir -
MCPD (webform-winform) / MCSA / MCDST / MCT
0
PCPT Messages postés 13280 Date d'inscription lundi 13 décembre 2004 Statut Membre Dernière intervention 3 février 2018 49
16 nov. 2009 à 15:40
(.... message supprimé, le code de la form n'est évidemment pas exécuté en mode design !!!)
0
hajerOnward Messages postés 22 Date d'inscription mercredi 23 mars 2005 Statut Membre Dernière intervention 17 novembre 2009
16 nov. 2009 à 15:57
en fait, les évènements OnLoad de chaque forme se lancent quand on affiche le DesignMode! donc on doit lui dire: si nous sommes en mode designer alors quitte la fonction
0
PCPT Messages postés 13280 Date d'inscription lundi 13 décembre 2004 Statut Membre Dernière intervention 3 février 2018 49
16 nov. 2009 à 16:11
hajerOnward -> depuis quand CTRL+TAB (basculer entre les onglets) implique-t'il un REBUILD ?!

le problème énoncé est que lorsque de l'affichage, en mode design (donc code de la form NON-EXECUTé!!), VS plante

(bon OK c'est mal dit, on a aucune info ni sur le projet, ni l'OS, les SP, la version de VS, ses SP....)


les choses qui sont executées dans VS sont :
*les addin
*certains contrôles (leur code donc) posés sur une form affichée, d'un projet ouvert (forcément en mode design)

pas le code de la form elle-même


imaginons donc qu'un timer est posé dans un usercontrol, timer à ON qui execute je ne sais quelle action à chaque tick...
le usercontrol posé sur la form, le code du timer va bel est bien s'executer en mode design comme en mode execution

le même code dans la form, le timer directement sur la form, PAS d'execution de code en mode design
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
hajerOnward Messages postés 22 Date d'inscription mercredi 23 mars 2005 Statut Membre Dernière intervention 17 novembre 2009
16 nov. 2009 à 16:11
je pensais que le problème est chez sultan27 :)
0
PCPT Messages postés 13280 Date d'inscription lundi 13 décembre 2004 Statut Membre Dernière intervention 3 février 2018 49
16 nov. 2009 à 16:20
oui et?
l'énoncé manque de précisions pour proposer une réponse (version vs, version win, explication du projet, usercontrols, etc...)
c'est pourquoi je n'ai indiqué aucune piste

ce n'est néanmoins pas une raison pour indiquer n'importe quoi et donc donner des informations totalement erronées ! aussi pour les autres lecteurs à venir
0
Rejoignez-nous