Problème avec "position : fixed ;" [Résolu]

Signaler
Messages postés
130
Date d'inscription
vendredi 5 octobre 2007
Statut
Membre
Dernière intervention
29 octobre 2012
-
Messages postés
130
Date d'inscription
vendredi 5 octobre 2007
Statut
Membre
Dernière intervention
29 octobre 2012
-
Bonjour,



<?xml:namespace prefix o ns "urn:schemas-microsoft-com:office:office" /??>
 




Je n’arrive pas à résoudre le souci suivant (les pages ne sont pas en lignes, c’est du local):



 




J’ai des boites placées à gauche dans lesquelles figurent des liens. Ces boites sont placées dans une colonne, et je veux qu’elles restent fixes, c'est-à-dire qu’elles ne descendent pas ni ne montent quand on descend ou remonte la page avec le scrollbar traditionnellement présent à droite. J’ai donc rajouté l’attribut «  position : fixed ;  ».



 




Mais alors, mes boites passent à droite de la page. J’ai beau changer les floats, les supprimer, mettre l’attribut tantôt dans les #, les .clas, rien n’y fait. Sauriez-vous résoudre cela, moi, je suis collé ?



 




Mes codes :




Css :


#col1


{




Position :fixed ;





width: 150px;



            float:left;


}


.clascolonne1


{


float:left;



            width:24px;



            height:21px;



            border-right:solid 2px #efefef;



            padding:0;



            margin:0;


}



 




#menu1


{



            border: solid 1px #9B999C;



            background-color: #EAEAEA;



            background-image: url("images/kko.gif");



            background-repeat: repeat-x;



            width: auto;



            margin-bottom: 10px;


}



 




#menu1 ul {



  margin:0;



  margin-top: 5px;



  margin-bottom: 5px;



  padding:1px;



  list-style-type:none;



 }



 




html :



              





                  

THE (GOOD) NEWS




                         




                         <li>[journal/academie/ Acad&eacute;mie de l'aurore]</li>



                        <li>[journal/Ecole_du_Vril/   title ="Voir la news">&eacute;cole du Vril]</li>
                        <li>[journal/archives/   title="Consultez les archives des news">Archives]</li>



                        






     
         





 





 





 





 




Je vous remercie par avance pour votre aide,


Bonne journée,







TOO
NIE

3 réponses

Messages postés
130
Date d'inscription
vendredi 5 octobre 2007
Statut
Membre
Dernière intervention
29 octobre 2012

J'ai résolu involontairement (mais c'est fait, là est finallement l'essentiel ) : j'ai voulu rajouté du "margin-top: 20px;" (j'avais laissé mon "position: fixed;" un peu par désespoir...) et ma surprise futr de constater que ça marchait !

Est-ce que le position: fixed; ne fonctionnerait qu'avec du margin quelque chose ? Bah, c'est résolu...!

TOO
NIE
Messages postés
13616
Date d'inscription
jeudi 13 février 2003
Statut
Membre
Dernière intervention
15 octobre 2013
34
Bonjour,

pas de col1 dans le html ?
si on met :     html :
                  

ça baigne

pour IE7, avec le bon doctype
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
    "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">

j'ai rien compris ?    c'est probable...

<hr />                Cordialement            Bul         [mon Site]     [M'écrire]
Messages postés
130
Date d'inscription
vendredi 5 octobre 2007
Statut
Membre
Dernière intervention
29 octobre 2012

Bonsoir Bultez,

Peut-êtreque si j'écrivais commeil faut, tout le monde comprendrais mieux...!


En fait, ce n'est pas #col1 mais #colonne1. Dans le html on retrouve donc le
.

TOO
NIE