Enum dans un WebControl [Résolu]

Signaler
Messages postés
1662
Date d'inscription
lundi 16 septembre 2002
Statut
Membre
Dernière intervention
30 juillet 2008
-
cs_GRenard
Messages postés
1662
Date d'inscription
lundi 16 septembre 2002
Statut
Membre
Dernière intervention
30 juillet 2008
-
Je recherche cette information avec l'erreur depuis plus de 2h et je ne trouve vraiment pas la réponse à cette question

Peut-on mettre un enum dans un WebControl?
Il semble que oui parce que le WebControl lui-même le fait.

Ceci est dans mon WebControl:







        public enum Format
        {
            Gif,
            Jpeg
        }

        Format format;
        public Format Format
        {
            get { return format; }
            set { format = value; }
        }








et dans ma page web



<%@ Register TagPrefix="bcg" Namespace="BarcodeGenerator" Assembly="BarcodeGenerator" %>






Et voici l'erreur que je reçois:





Compiler Error Message: CS0117: 'BarcodeGenerator.BarcodeGenerator' does not contain a definition for 'BarcodeGenerator'




En n'utilisant pas ce enum, il n'y a pas de problème et le script s'exécute.
Si je sors le enum de ma classe, l'erreur est alors:


Compiler Error Message: CS0117: 'BarcodeGenerator.BarcodeGenerator' does not contain a definition for 'Format'

Il est possible de mettre ce paramètre "Format" dans un codebehind lors de l'évènement Page_Load et aucune erreur ne se produit, mais je souhaitais pouvoir faire tout avec le HTML. Il y a-t-il un Import, Register, Reference? à mettre dans la page ASPX?

Merci

Jean-Sébastien Goupil

http://www.lookstrike.com

2 réponses

Messages postés
6814
Date d'inscription
dimanche 15 décembre 2002
Statut
Modérateur
Dernière intervention
13 octobre 2010
18
Bonjour,

Oui c'est possible. L'erreur que tu indique montre un problème au niveau de la reconnaissace de cette propriété dans la page web. Avec les éléments que tu donnes on ne peut pas savoir d'ou vient le problème, peux tu renommer ton contrôle en "suivant les recommandations de nommage", c'est à dire renommer ton assembly en MySociety.Web.ProjectName|ControlName, le namespace contenant ton control en MySociety.Web.UI.WebControls, car là tout s'appelle BarcodeGenerator (le controle, le namespace et l'assembly) et on ne sait pas de quoi le compilo parle.

De plus, pour résoudre ton problème, essaye de relancer Visual Studio, ou de tuer cassini (le mini serveur de développement) on dirait que l'assembly n'est pas pris en compte

<hr />Cyril - MSP - MCPD ASP.net & MCTS SQL - Consultant indépendant
Messages postés
1662
Date d'inscription
lundi 16 septembre 2002
Statut
Membre
Dernière intervention
30 juillet 2008
1
Haha, ouais c'est mélangeant :) désolé

J'ai mis "MyNamspace" et "MyClassname" et j'ai laissé l'Assembly.

Ca fonctionne... il y a un conflit quand on nomme tout pareil, il ne semble pas trouver qui est qui.

Je vais essayer de trouver des noms plus appropriés maintenant

Merci

, EssayezTestez avant de Poser une question !
http://www.lookstrike.com