Probleme de session chez 1et1

Résolu
Signaler
Messages postés
2
Date d'inscription
dimanche 20 mai 2007
Statut
Membre
Dernière intervention
18 février 2009
-
Messages postés
2480
Date d'inscription
jeudi 30 novembre 2006
Statut
Membre
Dernière intervention
14 janvier 2011
-
Salut a tout le monde;
je suis debutans dans le PHP

j'ai fais un espace menbre sur mon site, qui marche tres biens en local

Mais chez mon ebergeur 1et1 il ne marche pas, le problem c'est le PHP.ini de leur serveur et a ma conaissance c'est l'option: "session.use_trans_sid" qui est sur Off
Comment dois-je faire pour depasser ce probleme

je vous transmit la partie session du PHPinfo() de mon ebergere

Merci D'avence pour vos aides

======= la partie session du PHPinfo() de mon ebergere =========

sessionSession Support enabled
Registered save handlers files user

Directive Local Value Master Value
session.auto_start Off Off
session.bug_compat_42 On On
session.bug_compat_warn On On
session.cache_expire 180 180
session.cache_limiter nocache nocache
session.cookie_domain no value no value
session.cookie_lifetime 0 0
session.cookie_path / /
session.cookie_secure Off Off
session.entropy_file no value no value
session.entropy_length 0 0
session.gc_divisor 100 100
session.gc_maxlifetime 1440 1440
session.gc_probability 1 1
session.name PHPSESSID PHPSESSID
session.referer_check no value no value
session.save_handler files files
session.save_path /tmp /tmp
session.serialize_handler php php
session.use_cookies On On
session.use_only_cookies Off Off
session.use_trans_sid Off Off

2 réponses

Messages postés
1980
Date d'inscription
dimanche 20 février 2005
Statut
Membre
Dernière intervention
24 septembre 2012
5
Hello,

je ne me prononcerai pas sur la cause de ton problème, par contre si tu veux modifier le php.ini chez 1&1, faut mettre un fichier qui s'appelle comme ça à la racine et c'est toi qui choisis les valeurs qu'il contient.

à+
Messages postés
2480
Date d'inscription
jeudi 30 novembre 2006
Statut
Membre
Dernière intervention
14 janvier 2011
18
Salut,

Mettre la directive use_trans_sid à On dans la configuration du php.ini est moins sécurisé.
Cette option fait passer systématiquement le SID dans l'URL (toutes les URL sont réécrites à la volée par PHP) : ce n'est pas sécurisé parce que le SID transite dans toutes les URL.
A Off, le SID est stocké dans un cookie (qui reste "visible" par n'importe qui sur le net, mais qui moins facilement : on ne peut pas le copier/coller en donnant une URL à un ami).
Si on utilise correctement les sessions, on n'a pas besoin que cette directive soit à On.

<hr size="2" width="100%" />Neige

N'hésitez pas à lire la doc de PHP avant de poser des questions triviales...