Connexion mysql avec asp.net

Signaler
Messages postés
11
Date d'inscription
samedi 3 novembre 2007
Statut
Membre
Dernière intervention
16 juin 2009
-
Messages postés
11
Date d'inscription
samedi 3 novembre 2007
Statut
Membre
Dernière intervention
16 juin 2009
-
bonjour tout le monde ,j'ai un problème avec ma connection mysql avec asp.net ,ça fait une seamine que cherche la faute sur ce code:


<%@ Import Namespace="System.Data" %>
<%@ Import Namespace="System.Data.ODBC" %>
<script language="VB" Runat="server">
Sub Page_Load(Source as Object, E as EventArgs)
  BindData
    End Sub
    Sub BindData()
        Dim strConn As String
        strConn = "DRIVER={MySQLODBC 3.51 Driver};ServerAddress = localhost;DATABASE=hi;" & _
        "USER=root;PASSWORD=; OPTION=16386;"
        Dim MySQL As String = "Select * " & _
         " from moi"
        Dim MyConn As New ODBCConnection(strConn)
        Dim ds As DataSet = New DataSet()
        Dim Cmd As New ODBCDataAdapter(MySQL, MyConn)
        Cmd.Fill(ds, "moi")
        MyDataGrid.DataSource = ds.Tables("moi").DefaultView
        MyDataGrid.DataBind()
    End Sub
    Sub Page_Change(ByVal sender As Object, ByVal e As DataGridPageChangedEventArgs)
        MyDataGrid.CurrentPageIndex = e.NewPageIndex
        BindData()
    End Sub
</script>




<html xmlns="http://www.w3.org/1999/xhtml" >
<head runat="server">
<title>MySQL with ASP.Net</title>


<meta name="GENERATOR" content="asp express 4.0"/>


   
</head>

    <form id="form1" runat="server">
   
   
   


    </form>

</html>
 aidez moisvp

8 réponses

Messages postés
561
Date d'inscription
mardi 4 mars 2008
Statut
Membre
Dernière intervention
10 juin 2010

on peut savoir l'erreur que tu recois ?
Messages postés
11
Date d'inscription
samedi 3 novembre 2007
Statut
Membre
Dernière intervention
16 juin 2009

en réalité ce code me permet de récupérer tous les enregistrements de ma table "moi" mai il ne me déclare aucune faute mais ne me ré cupère rien .je pense qu'il manque quelque chose ,j'ai tous installé.aidez-moi svp.merci
Messages postés
561
Date d'inscription
mardi 4 mars 2008
Statut
Membre
Dernière intervention
10 juin 2010

essaie une fois

ds.Tables(0).DefaultView

ou
ds.Tables(0)
ou
ds.Tables("moi")
Messages postés
11
Date d'inscription
samedi 3 novembre 2007
Statut
Membre
Dernière intervention
16 juin 2009

j'ai essayé d'inserer dans ma table ,pour vérifier que  la connexion est établie mai la meme chose ,aucune erreur mais il n'insere rien:

<%@ Page Language="VB" AutoEventWireup="false" CodeFile="Default.aspx.vb" Inherits="_Default" %>




<%@ Import Namespace="System.Data" %>
<%@ Import Namespace="System.Data.ODBC" %>
<script language="VB" Runat="server">
Sub Page_Load(Source as Object, E as EventArgs)
  BindData
    End Sub
    Sub BindData()
        Dim nom
        Dim prenom
        Dim strConn As String
        nom = "han"
        prenom = "han"
       
        strConn = "DRIVER={MySQLODBC 3.51 Driver};ServerAddress = localhost;DATABASE=hi;" & _
        "USER=root;PASSWORD=; OPTION=16386;"
        Dim MySQL As String = "INSERT INTO moi (nom,prenom) " & _
        "values('" + nom + "','" + prenom + "' )"""
        Dim MyConn As New OdbcConnection(strConn)
        Dim ds As DataSet = New DataSet()
        Dim Cmd As New OdbcDataAdapter(MySQL, MyConn)
    
        Cmd.Fill(ds, "moi")
       
        MyDataGrid.DataSource = ds.Tables("moi").DefaultView
        MyDataGrid.DataBind()
    End Sub
    Sub Page_Change(ByVal sender As Object, ByVal e As DataGridPageChangedEventArgs)
        MyDataGrid.CurrentPageIndex = e.NewPageIndex
        BindData()
    End Sub
</script>


 




<html xmlns="http://www.w3.org/1999/xhtml" >
<head id="Head1" runat="server">
<title>MySQL with ASP.Net</title>


<meta name="GENERATOR" content="asp express 4.0"/>


   
</head>

    <form id="form1" runat="server">
   
   
   


    </form>

</html>
Messages postés
561
Date d'inscription
mardi 4 mars 2008
Statut
Membre
Dernière intervention
10 juin 2010

essaie ce que j'ai mis plus haut

en debug ca donne quoi ?

est ce que la requete fonctionne ?
Messages postés
11
Date d'inscription
samedi 3 novembre 2007
Statut
Membre
Dernière intervention
16 juin 2009

toujours la meme chose,a votre avis est ce que la connexion est établie ou non?je veux vérifier
Messages postés
561
Date d'inscription
mardi 4 mars 2008
Statut
Membre
Dernière intervention
10 juin 2010

si tu n'étais pas connecté tu aurais une exception générée

met un autogenerates sur les columns de ton grid

check en debug si tu as bien des données dans ton dataset
Messages postés
11
Date d'inscription
samedi 3 novembre 2007
Statut
Membre
Dernière intervention
16 juin 2009

comment ça j'ai pas compris ,je suis une débutante en visual.svp vous pouvez me réexpliquer