Compte cellules couleurs

Résolu
brownie0169
Messages postés
9
Date d'inscription
mercredi 9 août 2006
Statut
Membre
Dernière intervention
14 janvier 2008
- 10 janv. 2008 à 20:16
cs_MPi
Messages postés
3877
Date d'inscription
mardi 19 mars 2002
Statut
Membre
Dernière intervention
23 août 2018
- 12 janv. 2008 à 15:04
Bonjour
Sous Excel, quelqu'un pourrait il m'indiquer s'il est possible d'additionner les nombres dans des cellules mises en forme conditionnelle avec une formule? Lorsque la mfc est basée sur une valeur, pas de pb (ex: la valeur de la cellule est: =2008). Lorsque cette mfc se fait sur une formule, ça ne fonctionne pas (ex: La formule est: =$C$20). Existe t il une solution?
Je n'ai rien trouvé sur les forums...
D'avance merci.

9 réponses

fsltp
Messages postés
94
Date d'inscription
lundi 26 novembre 2007
Statut
Membre
Dernière intervention
16 janvier 2008

10 janv. 2008 à 21:11
Bonsoir,

avec la fonction somme.si en mettant le même critere que la mfc cela doit coller ?

a+
3
bigfish_le vrai
Messages postés
1835
Date d'inscription
vendredi 13 mai 2005
Statut
Membre
Dernière intervention
20 novembre 2013
12
10 janv. 2008 à 22:39
salut,

si je comprend bien tu voudrais qu'une celule qui contient une formule qui utilise la fonction somme, change de couleur quand le resultat est egale a 2008 ou 2007 etc ?

A+
3
bigfish_le vrai
Messages postés
1835
Date d'inscription
vendredi 13 mai 2005
Statut
Membre
Dernière intervention
20 novembre 2013
12
11 janv. 2008 à 06:02
... pardon une erreur c'est malicieusement inserée dans la formule

cette methode ne marche pas sur les colonnes entieres il faut donc ce limiter a un nombre de ligne comme par exemple :
{sum(if(B1:B100 2007, A1:A100,0)}

A+
3
cs_MPi
Messages postés
3877
Date d'inscription
mardi 19 mars 2002
Statut
Membre
Dernière intervention
23 août 2018
20
12 janv. 2008 à 15:04
Sans utiliser de "noms" de Range
=SOMME.SI(B:B;2007;A:A)

Pourquoi faire compliqué quand on peut faire simple...

MPi²
Pour ceux qui programment sous Office, n'oubliez pas qu'il existe un forum dédié à ces applications VBA....... ICI
3

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
brownie0169
Messages postés
9
Date d'inscription
mercredi 9 août 2006
Statut
Membre
Dernière intervention
14 janvier 2008

10 janv. 2008 à 21:48
Bonsoir
Bravo pour votre célérité et merci pour votre réponse.
Mais je viens de "tester", et je ne vois pas comment rentrer le critère demandé, qui ne être que du texte, expression ou nombre.(du moins je ne vois pas comment).
Ma mfc conditionelle:
la formule est: =$B5=2007
0
brownie0169
Messages postés
9
Date d'inscription
mercredi 9 août 2006
Statut
Membre
Dernière intervention
14 janvier 2008

10 janv. 2008 à 23:58
Bonjour
En fait, mon fichier contient des cellules mfc (police ) qui prennent une couleur définie (ici rouge) lorsque les cellulles B:B prennent la valeur 2007.Mon problème est que je souhaite faire la somme des chiffres rouges. Je n'ai rien trouvé à ce jour sur les forums, toutes les formules fonctionnent pour les mises en forme sur une valeur (valeur cellule=XXX) et non sur une formule (la formule est = =$B5=2007, dans mon cas).

<colgroup><col style=\"WIDTH: 60pt\" span=\"2\" width=\"80\" /></colgroup>----
4, 2007, ----
2, 2007, ----
3, 2007, ----
5, , ----
5, , ----
9
Pas évident à expliquer, et encore moins à solutionner.
Merci pour ta disponibilité.
0
bigfish_le vrai
Messages postés
1835
Date d'inscription
vendredi 13 mai 2005
Statut
Membre
Dernière intervention
20 novembre 2013
12
11 janv. 2008 à 05:22
... je suis desole mais je ne comprend toujours pas !?!?!

mais...

en regardant ton tableau ce que je crois comprendre c'est que tu voudrais prendre la valeur des celules en colonne A (par exemple)  quand la valeur de la celule d' à-coté, en colonne B contient une valeur en rouge et en faire la somme. Alors que d'autre part, ces valeurs en rouges sont elle meme pilotees par une mise en forme conditionel quand leur valeur est egale à 2007... pfff !... faudra pas dire que je n'essaye pas de comprendre .

Donc si je n'ai pas fait tout ca pour rien, je pense qu'une formule matricielle devrait suffire.

Si les celules qui contiennent une valeur rouge sont toujours = à 2007 il n'y qu'a chercher toute celle-ci en colonne B et de prendre la valeur d'en face en colonne A soit :
{sum(if(B:B 2007, A:A,0)} 

avec le tableau qui tu as posé ci-dessus cette formule retourne 9 soit 4+2+3.

une formule matricielle doit etre valider en maintenant appuié les touches Ctrl,Shift et Enter.
Une fois valider la formule sera encadree par des accolades.


A+


 
0
brownie0169
Messages postés
9
Date d'inscription
mercredi 9 août 2006
Statut
Membre
Dernière intervention
14 janvier 2008

11 janv. 2008 à 09:17
Bonjour
Voila mon tableau tel qu'il se présente. Les chiffres de la colonne A sont en rouge lorsque 2007 est affiché dans la colonne B par une mfc ("la formule est = =$B5=2007"). Je souhaite totaliser les chiffres en rouge de la colonne A


<colgroup>
<col style=\"WIDTH: 56pt; mso-width-source: userset; mso-width-alt: 2742\" width=\"75\" />
<col style=\"WIDTH: 53pt; mso-width-source: userset; mso-width-alt: 2560\" width=\"70\" />
</colgroup>

----

1
,

 
,

----

3,
2007,

----

2,
 ,

----

5,
 ,

----

58,
2007,

----

78,
 ,

----

3,
 
Encore merci pour ta disponibilité.
0
brownie0169
Messages postés
9
Date d'inscription
mercredi 9 août 2006
Statut
Membre
Dernière intervention
14 janvier 2008

11 janv. 2008 à 09:32
Rebonjour bigfish_le vrai
Ta solution est la bonne avec SOMME.SI; pour compléter, j'ai seulement nommé mes plages, et tout ça sans formule  matricielle:

'=SOMME.SI(millesime;2007;nombre)
Merci encore pour ton aide
@++
0