Perte de focus en Word 2010

Zermelo
Messages postés
378
Date d'inscription
samedi 22 septembre 2012
Statut
Membre
Dernière intervention
13 août 2017
- 22 févr. 2014 à 16:21
Zermelo
Messages postés
378
Date d'inscription
samedi 22 septembre 2012
Statut
Membre
Dernière intervention
13 août 2017
- 23 févr. 2014 à 09:02
Bonjour à toutes et à tous.

Dans mon Normal.dotm, j'ai créé un UserForm sur lequel j'ai déposé un certain nombre de boutons par lesquels j'appelle mes macros. Quand je clique sur l'un de ces boutons, le document actif perd le focus (ou ce qui en tient lieu). Bien sûr il suffit que je clique sur le document pour lui rendre le focus. Mais je préfèrerais que ce soit le code qui s'en charge.

Quelqu'un a-t-il une idée ?

Remerciements anticipés.

3 réponses

jordane45
Messages postés
36088
Date d'inscription
mercredi 22 octobre 2003
Statut
Modérateur
Dernière intervention
18 août 2022
351
22 févr. 2014 à 17:47
Bonjour,

Avec activate ?

Documents("nom de fichier" ).Activate

0
Zermelo
Messages postés
378
Date d'inscription
samedi 22 septembre 2012
Statut
Membre
Dernière intervention
13 août 2017
14
22 févr. 2014 à 18:11
Bonsoir Jordane45.

Merci pour votre réponse. J'ai essayé ActiveDocument.Activate, mais ce fut sans effet. Je vais essayer maintenant votre proposition, et je vous tiendrais au courant.

Cordialement.
0
Zermelo
Messages postés
378
Date d'inscription
samedi 22 septembre 2012
Statut
Membre
Dernière intervention
13 août 2017
14
23 févr. 2014 à 09:02
Bonjour Jordane45.

Je me suis trop avancé en disant que j'allais tester votre proposition. En effet, le code à écrire doit se trouver dans le Normal.dotm, pour s'appliquer à tous documents.

Cordialement.
0