Problème passage d'une séquence à l'autre

tibigorno Messages postés 5 Date d'inscription samedi 2 octobre 2004 Statut Membre Dernière intervention 28 décembre 2006 - 27 déc. 2006 à 23:37
tibigorno Messages postés 5 Date d'inscription samedi 2 octobre 2004 Statut Membre Dernière intervention 28 décembre 2006 - 28 déc. 2006 à 18:40
Bonjour à tous. Je ne pense pas d'après mes qques recherches, qu'l existe déjà un tel sujet.
Je vous présente mon probleme
Mon animation tourne sur 4 Séquences.
Sur la Deuxième (S2), 2 boutons dans deux calques différents, chacun amenant aux séquences suivantes ( (S3) et (S4) ).
Seulement il aparait que chacun des boutons amène à la même séquence, malgré ma vérification : les deux cibles sont distinctes

De plus, sur les séquences suivantes il y a un bouton pour revenir en arrière.
Sur (S3):        on (release) {prevFrame()
        }
et sur (S4):     on (release) {gotoAndPlay ("S2","1")
        }

Et à chaque fois pour la dernière séquence (S4), ça bloque : le bouton ne réponds pas à plusieurs cliques, puis au bout d'un certain nombre de clicks on est renvoyé au tout début de l'animation [ sur la séquence (S1) ] ...

J'suis pas bon en code, je travail principalemen en animation pure. [absolument pas le temps en terminale de me mettre au code] Mais là je comprends vraiment pas pourquoi ça ne marche pas.

Je vous viens donc en aide!

Merci par avance

Cordialement
vB

PS : Je "travaille" sur Flash8

2 réponses

celine2781 Messages postés 7 Date d'inscription lundi 13 novembre 2006 Statut Membre Dernière intervention 28 décembre 2006
28 déc. 2006 à 10:29
bonjour,

je suis debutante aussi mais peut etre que la syntaxe de ton script n'est pas bonne (tu n'as pas mis les " ; ")

on(release){
 gotoAndPlay("S2",1);
}

et mets un 
 stop();
sur l'image 1 de ta S2.

chez moi ça marche alors il ne devrait pas y avoir de raison....
0
tibigorno Messages postés 5 Date d'inscription samedi 2 octobre 2004 Statut Membre Dernière intervention 28 décembre 2006
28 déc. 2006 à 18:40
le stop est présent sur la première image. Et le " ; " aussi. Je ne comprends décidement pas ce qu'il se passe... Je vais tout recommencer plus tard, à tête reposée, et  tiendrai au courant

Merci ;)

vB
0