Problème avec VB

Signaler
Messages postés
50
Date d'inscription
dimanche 9 mai 2004
Statut
Membre
Dernière intervention
27 juillet 2007
-
Messages postés
50
Date d'inscription
dimanche 9 mai 2004
Statut
Membre
Dernière intervention
27 juillet 2007
-
Bonjour ,

  j'ai rencontré un problème avec VB c'est que le système quitte VB à chaque fois que j'ouvre certains formulaires ,
   merci de bien vouloir m'indiquer comment je peux  me débarasser de ce problème

12 réponses

Messages postés
7668
Date d'inscription
samedi 5 novembre 2005
Statut
Membre
Dernière intervention
22 août 2014
27
Sans ton code, çà va être simple !.... SUREMENT !
Messages postés
7393
Date d'inscription
mercredi 23 avril 2003
Statut
Membre
Dernière intervention
6 avril 2012
58
Salut,
Il va falloir être un peu plus précis si tu souhaites de l'aide rapide et précise.
Il y a t il des messages d'erreur ou quelque chose qui nous pemettrait de t'aider.
N'oublie pas que nous ne sommes pas devin.


@+: Ju£i?n


Pensez: Réponse acceptée
Messages postés
50
Date d'inscription
dimanche 9 mai 2004
Statut
Membre
Dernière intervention
27 juillet 2007
2
  pour etre plus précis ; j'ouvre mon projet , en mode edition , si j'affiche le code du formulaire en question rien ne se passe mais si je clique sur 'View object' ou en d'autre terme j'affiche le formulaire en mode design , le système quitte tout le projet .

NB le problème n'est pas dans mon code
Messages postés
695
Date d'inscription
jeudi 5 mai 2005
Statut
Membre
Dernière intervention
5 janvier 2010
31
Vu le probleme, moi je ferais une desinstallation et une reinstallation... Mais bon, il est vrai que ce genre de probleme m'exaspere au plus haut point et la meilleure solution est souvent la solution la plus radicale. Avant de suivre ma méthode, attends un peu quelqu'un pourrait peut être t'aider!!!

         (Si la réponse vous convient, appuyez sur réponse acceptée...).

                           Noubliez pas de lire le REGLEMENT 
Messages postés
50
Date d'inscription
dimanche 9 mai 2004
Statut
Membre
Dernière intervention
27 juillet 2007
2
C'est même pas lié à l'installation de VB  puisque je le teste dans un  autre poste et le poste persiste toujours
Messages postés
7668
Date d'inscription
samedi 5 novembre 2005
Statut
Membre
Dernière intervention
22 août 2014
27
Alors : ton fichier a été pollué (celà arrive) sans que tu en sois responsable.

Fais un nouveau projet, en réinjectant ton code par du copier-coller.


Une question toutefois : as-tu inséré un ocx ? (les ocx sont actifs dès leur insertion en mode design, s'ils sont programmés pour...)
Messages postés
50
Date d'inscription
dimanche 9 mai 2004
Statut
Membre
Dernière intervention
27 juillet 2007
2
j'utilise un  activeX  que j'insère dans mon formulaire qui fait appel à  un moteur  SIG
Messages postés
7668
Date d'inscription
samedi 5 novembre 2005
Statut
Membre
Dernière intervention
22 août 2014
27
As-tu le source de cet ocx ?
Sais-tu ce qu'il fait au design time ?


Il est peut-être (je dis bien peut-être) le véritable responsable ...
Messages postés
3877
Date d'inscription
mardi 19 mars 2002
Statut
Membre
Dernière intervention
23 août 2018
19
Je pense la même chose que jmfmarques

MPi
Messages postés
50
Date d'inscription
dimanche 9 mai 2004
Statut
Membre
Dernière intervention
27 juillet 2007
2
oui il s'exécute au design time  comme au run time , y a il  quelques choses à faire ?
Messages postés
7668
Date d'inscription
samedi 5 novembre 2005
Statut
Membre
Dernière intervention
22 août 2014
27
As-tu donc, dans ce cas, OUI ou NON, le source de cet ocx  ? (ce source est nécessaire si l'on veut voir ce qu'il fait au design time et (surtout) ce qu'il fait lorsqu'on l'interromp (en le supprimant, entre autres, mais pas seulement !).

Question : d'où vient cet ocx ?
Messages postés
50
Date d'inscription
dimanche 9 mai 2004
Statut
Membre
Dernière intervention
27 juillet 2007
2
non je n'ai pas le code