ADDRESS=(PROTOCOL=beq)... erreur d'adaptateur de protocole

Signaler
Messages postés
75
Date d'inscription
jeudi 27 janvier 2005
Statut
Membre
Dernière intervention
17 octobre 2008
-
Messages postés
75
Date d'inscription
jeudi 27 janvier 2005
Statut
Membre
Dernière intervention
17 octobre 2008
-
Bonjour.
J'espère poster sur le bon forum et je suis désolé si ce n'est pas le cas...

Donc j'ai un formulaire php qui me permet de sélectionner des champs qui vont constituer une requête.
Cette requête est transmise à un vbscript de cette façon (pour être exécuté en tache de fond):

pclose(popen("start /b wscript.exe "mon_script.vbs" "".requete.""", 'r'));
 

Le script se connecte à une base orcale, exécute la requête et génère un fichier texte avec le résultat de celle ci.

Mon problème c'est que lorsque que je post plusieurs fois mon formulaire (en sélectionnant des champs différents ou pas), J'ai plusieurs fichiers qui sont vide est un fichier sqlnet.log qui est généré avec :



Fatal NI connect error 12560, connecting to:
 (DESCRIPTION=(ADDRESS=(PROTOCOL=BEQ)(PROGRAM=oracle)(ARGV0=oracleORCL)(ARGS='(DESCRIPTION=(LOCAL=YES)(ADDRESS=(PROTOCOL=beq)))'))(CONNECT_DATA=(SID=ORCL)(CID=(PROGRAM=C:\WINDOWS\system32\wscript.exe)(HOST=nom_serevur)(USER=SERVICE?R?SEAU))))
<?xml:namespace prefix o ns "urn:schemas-microsoft-com:office:office" /??>








 


VERSION INFORMATION:
 TNS for 32-bit Windows: Version 9.2.0.1.0 - Production
 Oracle Bequeath NT Protocol Adapter for 32-bit Windows: Version 9.2.0.1.0 - Production
  Time: 31-AOU-2006 18:29:41
  Tracing not turned on.
 


Tns error struct:
    nr err code: 0
    ns main err code: 12560
    TNS-12560: TNS : erreur d'adaptateur de protocole
    ns secondary err code: 0
    nt main err code: 530
    TNS-00530: Erreur d'adaptateur de protocole
    nt secondary err code: 126
    nt OS err code: 0



Ce que je ne comprends pas c'est PROTOCOL=BEQ je n'ai rentré nul par BEQ ??? mais tcp dans le tnsname.ora. Je pense donc que erreur d'adaptateur de protocole

viens du Beq.

Que puis-je faire ?

Merci.

3 réponses

Messages postés
75
Date d'inscription
jeudi 27 janvier 2005
Statut
Membre
Dernière intervention
17 octobre 2008
1
Je sais pas si je me suis bien fait comprendre. Lorsque que je lance plusieur requetes, j'ai des fichiers vide et d'autre remplis normalement (tout ne plante pas)

Merci.
Messages postés
75
Date d'inscription
jeudi 27 janvier 2005
Statut
Membre
Dernière intervention
17 octobre 2008
1
Je viens de m'apercevoir que sur mon poste cela fonctionne ( windows 2000 pro, oracle 8) mais c'est sur le serveur que cela ne marche pas ( windows 2003 serveur, oracle 9i )


Svp un coup de main.
Messages postés
75
Date d'inscription
jeudi 27 janvier 2005
Statut
Membre
Dernière intervention
17 octobre 2008
1
J'ai installer le 9i sur mon poste est ca marche quand meme???