Modification par formulaire d'un contenu d'une base Mysql

Signaler
Messages postés
57
Date d'inscription
samedi 30 avril 2005
Statut
Membre
Dernière intervention
12 septembre 2009
-
Messages postés
57
Date d'inscription
samedi 30 avril 2005
Statut
Membre
Dernière intervention
12 septembre 2009
-
bonsoir,

j'ai un petit souci dans ma page de modification d'un contenu provenant d'une base.
mon problème : le contenu présent dans le value d'un formulaire est en partie répéter.Je ne sais vraiment pas d'ou le problème peu venir?mon code à l'air correct il fonctionne mise à par la répétition qui apparait.

modification.php(simplifié):
...
htmlarea
...
<?php
//récupération de la variable d'URL,
//qui va nous permettre de savoir quel enregistrement modifier
$id_page = $_GET["id_page"] ;
//requête SQL: $sql "SELECT contenucadre1_page FROM pages WHERE id_page ".$id_page ;


//exécution de la requête:
$requete = mysql_query( $sql) ;

//affichage des données:
if( $result = mysql_fetch_array( $requete ) )
{
?>
<form name="formpage" action="modification2.php" method="POST">
">
<textarea name="contenucadre1_page" cols="45" rows="15"
value="<?php echo addslashes($result['contenucadre1_page']);?>" >
<?php echo $result['contenucadre1_page'] ;></textarea>

</form>
<?php
}//fin if

Une répétition partiel du contenu apparait au dessus du contenu "correct"
la répétition fini par ceci: ">

quelqu'un aurait il une idée d'où pourrait venir mon erreur? parceque en locale çà marche mais pas sur le net?

2 réponses

Messages postés
3
Date d'inscription
mardi 6 décembre 2005
Statut
Membre
Dernière intervention
8 décembre 2005

je croi qta fai une erreur de code a cet endroit : (en gras)....

<textarea name="contenucadre1_page" cols="45" rows="15"
value="<?php echo addslashes($result['contenucadre1_page']);?>" >
<?php echo $result['contenucadre1_page'] ;></textarea>

test de l'enlever et dis moi...
Messages postés
57
Date d'inscription
samedi 30 avril 2005
Statut
Membre
Dernière intervention
12 septembre 2009

merci pour ton aide
je crois que je vois ou se trouve mon erreur
il s'agit du premier echo car il n'y a pas de value dans "textarea" (contrairement au "input")
je crois que ç çà qui provoque ses bug et la répétition partiel du contenu.

merci