Petit problème sous ASP.Net - Débutant en ASP. Net [Résolu]

Signaler
Messages postés
2641
Date d'inscription
mercredi 2 juin 2004
Statut
Membre
Dernière intervention
8 janvier 2014
-
Messages postés
2641
Date d'inscription
mercredi 2 juin 2004
Statut
Membre
Dernière intervention
8 janvier 2014
-
Salut à tous, voilà j'ai un serveur web proposant des bases de données SQL, ça je sais gérer, mon pb c'est que j'ai donc fait la connection à ce serveur dans VS.Net, je lance la page Aspx, là je remplis les champs désirer, je construit la SelectCommand, mais j'ai le pb suivant au niveau du .Fill :

Fill : la propriété SelectCommand.Connection n'a pas été initialisée

Voici le code :

SqlDataAdapter1.SelectCommand = New System.Data.SqlClient.SqlCommand("SELECT * FROM Clients WHERE [User]='" & UserBox.Text & "'")
SqlConnection1.Open() 'Connection à la base : ok
SqlDataAdapter1.Fill(DataSet11) 'Ici j'ai le pb

Merci d'avance de votre aide

Chris
A voir également:

2 réponses

Messages postés
1642
Date d'inscription
samedi 6 novembre 2004
Statut
Modérateur
Dernière intervention
28 avril 2011
2
Salut,

Ton problème vient du fait que tu ne dis pas quelle connexion doit utiliser ton SqlCommand.

fait plutôt ça :



SqlDataAdapter1.SelectCommand = New
System.Data.SqlClient.SqlCommand("SELECT * FROM Clients WHERE [User]='"
& UserBox.Text & "'")

SqlDataAdapter.SelectCommand.Connection = SqlConnection1 ' tu remplis l'objet Connexion avec ta connexion

SqlDataAdapter.SelectCommand.Connection.Open() ' et ensuite tu l'ouvres

SqlDataAdapter1.Fill(DataSet11) ' et là : plus de problème !



J'ai pas testé, mais, de mémoire, ça doit être ça


A+++

Nurgle
Il est plus aisé d'être sage pour les autres que pour soi-même ! (La Rochefoucauld)
Messages postés
2641
Date d'inscription
mercredi 2 juin 2004
Statut
Membre
Dernière intervention
8 janvier 2014
14
Top cool, ça marche nickel sans problème !
merci merci