Impossible d'ouvrir un fichier

Résolu
Signaler
Messages postés
155
Date d'inscription
lundi 10 janvier 2005
Statut
Membre
Dernière intervention
17 juillet 2008
-
Messages postés
308
Date d'inscription
mardi 11 juin 2002
Statut
Membre
Dernière intervention
26 septembre 2008
-
Salut,



J'ai installer delphi 6 sur mon ordinateur, et j'essaye d'ouvrir une
fiche contenant des composants flat, j'ai donc téléchargé ces
composants sur http://www.afalinasoft.com/ , je les ai installé, et
jusque là je ne voyais pas de problèmes, j'ai fais exactement ce qu'il
fallait (enfin je crois lol). Mais dès que j'ouvre la fiche, j'ai un
message d'erreur de ce style pour chacun des composants flat de la
fiche :



Erreur de lecture de la fiche



Classe TFlatPanel non trouvée. Ignorer l'erreur et continuer ? Remarque
: ceci peut provoquer la suppression de composants ou la perte de
valeurs de propriétés.





Pourtant j'arrive à utiliser les composants, comment faire ????





Merci d'avanc

3 réponses

Messages postés
308
Date d'inscription
mardi 11 juin 2002
Statut
Membre
Dernière intervention
26 septembre 2008

bonjour j'ai téléchargé le composant pour tester ,pour ma part les composants db me sont inaccessible quand je compile le pack or en supprimant des uses ce que le compilateur ne trouve pas ,j'arrive à installer le pack ...

J'ai donc maintenant un onglet de composants flatControl.

je cré un nouveau projet ,j'insère un flatlabel ,je compile ....fCtrls.dcu not found, je copie ce fichier dans le même répertoire ok, fUtils.dcu not found idem,fCtrls.dcr idem alors là ^ca fonctionne ...Lorsque je vais réouvrir le projet je n'aurai pas ce message d'erreur tFlatLabel not found....
Messages postés
308
Date d'inscription
mardi 11 juin 2002
Statut
Membre
Dernière intervention
26 septembre 2008

bon c'est normal ,delphi est brillant mais on doit l'aider un peu !!! Dans les options du projets, indique au compilateur où se trouve les unités du composant...

sinon même si les .dcu et les .pas étant placer dans le même répertoire delphi ne les utilisera pas à moins bien sur de les ajoutées au projet avec la commande add...

yve
Messages postés
155
Date d'inscription
lundi 10 janvier 2005
Statut
Membre
Dernière intervention
17 juillet 2008

mais les composants sont très bien installés, j'arrive a les utiliser, c'est juste quand j'ouvre un fichier flat qu'il me met ça