Php et js/activex

Signaler
Messages postés
42
Date d'inscription
mardi 29 juin 2004
Statut
Membre
Dernière intervention
12 septembre 2015
-
Messages postés
9433
Date d'inscription
mardi 9 octobre 2001
Statut
Membre
Dernière intervention
13 avril 2007
-
Bonjour,
je cherche a comprendre ce qui ne marche pas dans mon petit script :
<script>function delf() {
var fso = new ActiveXObject("Scripting.FileSystemObject");
var delf = fso.DeleteFile("toto.txt");}</script> et cette fonction est appelee dans un lien href="javascript:delf()".

Le pb:
Lorsque je mets ce script dans une page .html seule, ca marche.
Par contre, lorsque je le mets dans une page .php qui est inseree dans ma page principale par un include, là j'ai le message "un composant activex ne peut pas creer un objet" ,ca plante et mon fichier n'est pas efface...

qqn a-t-il une idee...merci,
noone.1

3 réponses

Messages postés
9433
Date d'inscription
mardi 9 octobre 2001
Statut
Membre
Dernière intervention
13 avril 2007
8
Salut ;-)

Le fichier que tu inclues est dans un autre répertoire ?

a ++

http://www.vulgarisation-informatique.com : entraide, dépannage et vulgarisation informatique
Messages postés
42
Date d'inscription
mardi 29 juin 2004
Statut
Membre
Dernière intervention
12 septembre 2015

bonjour,
non, ils sont tous a la racine...
est-ce un pb dans mon script, dans la config d'IE ou bien est-ce un comportement normal de php...
Messages postés
9433
Date d'inscription
mardi 9 octobre 2001
Statut
Membre
Dernière intervention
13 avril 2007
8
Je dirais de IE si la source envoyée au navigateur est la même.

a ++

http://www.vulgarisation-informatique.com : entraide, dépannage et vulgarisation informatique