Préchargement et séquences

Signaler
Messages postés
40
Date d'inscription
mardi 7 janvier 2003
Statut
Membre
Dernière intervention
15 mars 2005
-
Messages postés
40
Date d'inscription
mardi 7 janvier 2003
Statut
Membre
Dernière intervention
15 mars 2005
-
Bonjour à tous,
j'ai un gros soucis et je n'arrive pas à y remédier (en plus je ne suis pas super forte en actionscript)
voilà : je suis en train de réaliser un site web totalement en flash.
Suite à un bug que je ne comprends toujours pas, j'ai du placer toutes les pages sur des frames différentes (et non des séquences différentes ou fichiers swf externes).
J'ai néanmoins pu terminer ce site au code assez pourri, mais impossible de faire un préchargement, même en le placant sur la première frame de la même séquence.
J'ai essayé de faire un
trace (_root.getBytesLoaded());
mais ça me met undefined

bref je suis paumée si quelqu'un pouvait m'aider merci ://

Lotte :kisses)

2 réponses

Messages postés
91
Date d'inscription
mardi 24 décembre 2002
Statut
Membre
Dernière intervention
23 février 2007

si tu veut j'ai un peu de temps devant moi et je veut bien te filer un coup de main

le plus simple c ke tu m'envoie le fla a cette adresse

guillaume@modernprimitive.net

(si il fait pas plus de 4Mo )
Messages postés
40
Date d'inscription
mardi 7 janvier 2003
Statut
Membre
Dernière intervention
15 mars 2005

Bon j'ai à peu près réglé le problème. Il se trouve que le préchargement s'effectuait, mais qu'après le chargement des sons (qui sont très lourds), donc on ne voyait que les 10 derniers pourcentages.
J'ai donc choisi de mettre les sons en externe, et j'ai même créé un préchargement pour ces sons (suis trop fière de moi lol)
Par contre maintenant j'ai un autre soucis :
lorsque je teste l'anim en local, no pb
lorsque je teste sur le réseau, le son et l'anim ne sont pas synchro. Bizarre en ayant fait un préchargement ???
J'ai vu des posts à ce sujet sur ce site, mais ils ne parlent que de sons importés dans flash (apparemment on y remédie en faisant du streaming, cad en positionnant le son sur "continu"). Mais dans le cas de sons externes ???
J'ai pensé à réintégrer ces sons dans mon flash et les mettre en continu, seulement dans ce cas le préchargement ne marche pas (là aussi lu des posts à ce sujet et personne n'indique de solution...)

HEeeeeeeeeeelp je suis paumée !! (et cette anim devrait déjà être terminée, je vais me faire taper dessus)

Lotte :kisses)