PHP_SELF

Signaler
Messages postés
91
Date d'inscription
samedi 8 mars 2003
Statut
Membre
Dernière intervention
5 août 2010
-
Messages postés
236
Date d'inscription
vendredi 21 février 2003
Statut
Membre
Dernière intervention
18 juillet 2006
-
http://www.phpcs.com/code.aspx?ID=21675
est ce que quelqu'un peu me dire pk avec easyphp1.7 ça bug ds tt les sens... et me coorigé mon src marci d'avance
PhPeteur

5 réponses

Messages postés
236
Date d'inscription
vendredi 21 février 2003
Statut
Membre
Dernière intervention
18 juillet 2006
1
il a y de petits changements au niveau de easyphp 1.7. notamment dans la configuration de depart..
dans le php.ini le register_glogals off et le error_reporting e_all

Dans ton cas c'est parce que les variables utilisees dans la sources ne snt pas initialiées. Alors vu que le easyphp 1.7 par defaut reporte toutes les erreurs, notices et avertissements tu vois ces messages.

pour les enlever, ajoute au debut de ta source celle ligne. tu verras c'est magique :)

<?php error_reporting(E_ERROR | E_PARSE | E_WARNING); ?>


++

Le meilleur langage de programmation est un étudiant diplomé.. 8-)
Messages postés
91
Date d'inscription
samedi 8 mars 2003
Statut
Membre
Dernière intervention
5 août 2010

Merci bien.
j'avais réussi a le faire fonctionner qd même mais ce petit code me servira pour mes ancien script qui serai long a mettre a jour...
Une dernière question pourquoi
http://jonguignolo.chez.tiscali.fr/index.php
mon script ne marche pa chez mon hebergeur alors qu'en local il marche ???
sniff

PhPeteur
Messages postés
236
Date d'inscription
vendredi 21 février 2003
Statut
Membre
Dernière intervention
18 juillet 2006
1
je me suis rendu sur la page .. tout semble bien marcher.. !

++

Le meilleur langage de programmation est un étudiant diplomé.. 8-)
Messages postés
91
Date d'inscription
samedi 8 mars 2003
Statut
Membre
Dernière intervention
5 août 2010

Normal juste aprés t'avoir dit que j'avais un pb j'ai mis mon script a jour si on peu dire ainsi j'ai du comment dire descendre la version de mon script le desupgradé tu vois? parceke tiscali ne prend pas php 4.3.3
voila ;) merci pour ton aide ++
PhPeteur
Messages postés
236
Date d'inscription
vendredi 21 février 2003
Statut
Membre
Dernière intervention
18 juillet 2006
1
de rien.. ;)

Le meilleur langage de programmation est un étudiant diplomé.. 8-)