Problème mysql_fetch_array

Messages postés
312
Date d'inscription
vendredi 4 avril 2003
Statut
Membre
Dernière intervention
14 septembre 2004
- - Dernière réponse : Tomcube
Messages postés
312
Date d'inscription
vendredi 4 avril 2003
Statut
Membre
Dernière intervention
14 septembre 2004
- 14 nov. 2003 à 23:19
voilà mon prob,

je fais une requête toute con sur une table que je vien de créer :
"select * from recettes"

La structure de ma table est celle-ci :

CREATE TABLE `recettes` (
`Rid` int(10) unsigned NOT NULL auto_increment,
`RCid` int(10) unsigned NOT NULL default '0',
`titre` varchar(155) NOT NULL default '',
`intro` varchar(255) NOT NULL default '',
`ingredients` text NOT NULL,
`preparation` text NOT NULL,
`presentation` varchar(255) default NULL,
`tps_prep` int(5) unsigned NOT NULL default '0',
`tps_cuis` int(5) unsigned NOT NULL default '0',
`difficulte` char(1) NOT NULL default '1',
`image` varchar(155) NOT NULL default '',
`nb_personne` int(2) unsigned NOT NULL default '0',
PRIMARY KEY (`Rid`)
) TYPE=MyISAM PACK_KEYS=0 AUTO_INCREMENT=2 ;

D'abord, dans mon code, je teste le mysql_num_rows qui me renvoi "1" >> normal
Mais maintenant je voulais faire comme d'ab, un :
whille(mysql_fetch_array($result))
{
// instructions
}

Mais il n'exécute pas la boucle ...
C'est la première fois que ça m'arrive, savez-vous de quoi ça vient ?
Afficher la suite 

1 réponse

Messages postés
312
Date d'inscription
vendredi 4 avril 2003
Statut
Membre
Dernière intervention
14 septembre 2004
1
0
Merci
Laissez tomber c'était un problème qui venait du fait que j'ai appelé la mauvaise fonction de ma classe BDD que je suis en train de faire. Désolé, par contre, j'ai un autre problème donc je poste un autre topic.
Commenter la réponse de Tomcube