Ssl

Signaler
Messages postés
42
Date d'inscription
lundi 20 février 2012
Statut
Membre
Dernière intervention
15 juin 2012
-
Messages postés
1309
Date d'inscription
samedi 31 janvier 2009
Statut
Membre
Dernière intervention
5 juin 2013
-
bonjour;
Je veut configurer mon appache (j travaille sous wampserver v2.2.11)
j'ai mis ce code dans httpd.conf

Listen 443

<VirtualHost _default_:443>
DocumentRoot /home/httpd/private
ErrorLog /usr/local/apache/logs/error_log
TransferLog /usr/local/apache/logs/access_log
SSLEngine on
SSLProtocol all -SSLv2
SSLCipherSuite ALL:!ADH:!EXPORT:!SSLv2:RC4+RSA:+HIGH:+MEDIUM

SSLCertificateFile /usr/local/apache/conf/ssl.crt
SSLCertificateKeyFile /usr/local/apache/conf/ssl.key
SSLCertificateChainFile /usr/local/apache/conf/sub.class1.server.ca.pem
SSLCACertificateFile /usr/local/apache/conf/ca.pem
SetEnvIf User-Agent ".*MSIE.*" nokeepalive ssl-unclean-shutdown
CustomLog /usr/local/apache/logs/ssl_request_log \
"%t %h %{SSL_PROTOCOL}x %{SSL_CIPHER}x "%r" %b"
</VirtualHost>


et j'ai decommenter les 2lines:

LoadModule ssl_module modules/mod_ssl.so
include conf/extra/httpd-ssl.conf


puis j'ai mis ans le repertoire conf ces 2 certifs


ca.pem et sub.class1.server.ca.pem


svp aidez moi je veut quemon site soit sécuriser avec le cadenas




merci

1 réponse

Messages postés
1309
Date d'inscription
samedi 31 janvier 2009
Statut
Membre
Dernière intervention
5 juin 2013
12
Salut,

j travaille sous wampserver v2.2.11

Étrange, quand ej regarde ta conf je constate que tous les chemins que tu as mis sont des chemins *nix. J'en conclu que soit tu n'es pas sous windows soit tu as "pompé" la configuration sans réfléchir.

Déjà, tu devrais ne faire ton VirtualHost que si tu es certain que le mod ssl soit bien chargé. Pour ceci, il suffis d'utiliser :
<VirtualHost *:443>
  # ta config
</VirtualHost>


Vu que l'on utilise un virtualhost, il faut bien définir son nom ainsi que pas mal de petites choses indispensables (répertoire par défaut etc), bref totu ce qui serait nécessaire pour faire tourner le site sans ssl. Ensuite on ajoute ce qui est propre au ssl. Voici ce que j'utilise comme config, tu devrais pouvoir t'en servir afin d'adapter à ton cas :
<VirtualHost *:443>
        ServerName example.com
        ServerAlias www.example.com
        ServerAdmin webmaster@example.com

        DocumentRoot /var/www/example.com
        <Directory />
                Options +FollowSymLinks
                AllowOverride None
        </Directory>
        <Directory /var/www/example.com/>
                Options -Indexes +FollowSymLinks -MultiViews
                AllowOverride All
                Order allow,deny
                allow from all
        </Directory>

        ErrorLog ${APACHE_LOG_DIR}/error.log
        LogLevel warn
        CustomLog ${APACHE_LOG_DIR}/ssl_access.log combined

        SSLEngine on
        SSLCertificateFile /chemin/vers/le/certif.crt

        <FilesMatch "\.(cgi|shtml|phtml|php)$">
                    SSLOptions +StdEnvVars
        </FilesMatch>

        BrowserMatch "MSIE [2-6]" \
                nokeepalive ssl-unclean-shutdown \
                downgrade-1.0 force-response-1.0
        BrowserMatch "MSIE [17-9]" ssl-unclean-shutdown
</VirtualHost>