Proleme de connexion avec le .jar

hfdz Messages postés 8 Date d'inscription samedi 22 novembre 2008 Statut Membre Dernière intervention 12 juin 2012 - 18 oct. 2011 à 11:09
cs_Julien39 Messages postés 6414 Date d'inscription mardi 8 mars 2005 Statut Modérateur Dernière intervention 29 juillet 2020 - 8 nov. 2011 à 07:49
Bonjour a tous

j'aurai besoins de votre aide si vous voulez bien .

voila je suis entrain de développer une application en java sous éclipse avec connexion a la base de données (MySQL).

j'ai copier le connecteur mySQL (.jar) sur ma machine, et meme le classPath y fait reference, et quand je lance l'application ça tourne parfaitement.

mais quand je crée un executable (.jar) la il me dis qu'il ne trouve pas le connecteur "com.mysql.jdbc.Driver"


avez vous une idée s'il vous plait

merci d'avance

5 réponses

cs_Julien39 Messages postés 6414 Date d'inscription mardi 8 mars 2005 Statut Modérateur Dernière intervention 29 juillet 2020 367
20 oct. 2011 à 13:03
Bonjour,

Es tu certain que tu as bien inséré le connecteur dans le .jar lors de l'export ? Je te conseil de ne le placer que dans le classpath.

Est ce que tu utilises un ide ou bien fais tu la compilation à la main ?

Tu peux renommer ton .jar en .zip pour parcourir son contenu.
0
cs_Julien39 Messages postés 6414 Date d'inscription mardi 8 mars 2005 Statut Modérateur Dernière intervention 29 juillet 2020 367
7 nov. 2011 à 15:06
Toujours pas de réaction ?

Pour qu'on t'aide, il faudrait que tu fasses un minimum d'efforts...
0
hfdz Messages postés 8 Date d'inscription samedi 22 novembre 2008 Statut Membre Dernière intervention 12 juin 2012
7 nov. 2011 à 17:15
Bonjour,

désolé pour ce silence, mais j'ai résolu le probleme
voila pour ce que rencontre le meme probleme :

il faut placer le .jar(executable) dans le meme de dossier que les source, et ensuite si on veut on peut créer un raccourci a partir de la et le mettre ou on veut .

merci a vous
0
cs_GodConan Messages postés 2113 Date d'inscription samedi 8 novembre 2003 Statut Contributeur Dernière intervention 6 octobre 2012 12
7 nov. 2011 à 17:16
salut,

ton connector (jar) normalement, il suffit de le mettre dans le rep ext de ta jre active ;o) ...
sous eclipse tu peu choisir une jre par projet ;o) fait attention, et tu peux aussi inserrer ton connector explicitement au niveau du projet en librairie externe... bien que cela fasse lontemps que je n ais utilisé eclipse ;o) je ne pense pas que cela ait changé ;o) tous les IDE le font ;o) héhé ;o) ...

le mieu serait quand meme de nous donner exactement ton message d erreur ;o)

GodConan ;o)
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
cs_Julien39 Messages postés 6414 Date d'inscription mardi 8 mars 2005 Statut Modérateur Dernière intervention 29 juillet 2020 367
8 nov. 2011 à 07:49
Ca sent l'utilisation des chemins relatifs à mauvais escient. Ce n'est pas comme cela que ca doit fonctionner normalement. Ton .jar, tu peux le mettre ou tu veux et tu n'as pas besoin du dossier sources pour le faire fonctionner.

Comme le dis GodConan, si tu nous donne la trace de ton erreur, nous pourrons t'en dire plus.
0