Barre de défileement horizontale trop longue [Résolu]

Messages postés
31
Date d'inscription
jeudi 25 mars 2010
Statut
Membre
Dernière intervention
18 septembre 2010
- - Dernière réponse : BenamourJr
Messages postés
31
Date d'inscription
jeudi 25 mars 2010
Statut
Membre
Dernière intervention
18 septembre 2010
- 5 avril 2010 à 20:53
Je viens de positionner quelques éléments de mon design via CSS et j'ai remarqué que depuis la barre de défilement horizontale est trop longue par rapport à ce qui est affiché à l'écran...
Voyez plutôt: http://e-storia.info/design.php
D'où cela peut provenir ?
Je vous montre ma feuille de style, j'espère que ce sera suffisant pour que vous puissiez m'aider :)

/* CSS sur les balises */

body
{
width: 960px;
margin: auto;
margin-top: 15px; 
margin-bottom: 15px;
font-family: "Trebuchet MS", serif;
font-size: 16px;
background-image: url("background-newspaper.gif");
}

a
{
text-decoration: none;
}

/* Blocks composants le design */

#menu-haut
{
width: 960px;
height: 30px;
}

#banniere
{
width: 960px;
height: 150px;
background-image: url("banniere2.jpg");
background-repeat: no-repeat;
}

#menu-bas
{
width: 960px;
height: 47px;
background-image: url("recherche.png");
background-repeat: no-repeat;
}

#corps-haut
{
width: 960px;
height: 47px;
text-align: right;
}

#corps
{
width: 940px;
padding: 8px;
border: 2px solid #000000;
background-color: #ffffff;
}

/* Espace membre */

.avatar
{
position: relative;
left: 650px;
top: 25px;
}

/* Espace membre : non-connecté */

.pseudo
{
position: relative;
left: 768px;
bottom: 98px;
}

.mdp
{
position: relative;
left: 768px;
bottom: 103px;
}

.connexion_auto
{
position: relative;
left: 764px;
bottom: 111px;
}

.connexion_auto_label
{
color: #ffffff;
font-size: 13px;
position: relative;
bottom: 2px;
}

.go
{
position: relative;
left: 917px;
bottom: 213px;
}

.lien_connexion
{
color: #ffffff;
font-size: 13px;
position: relative;
left: 765px;
bottom: 193px;
}

.lien_connexion2
{
color: #ffffff;
}

/* Espace membre : connecté */

.pseudo
{
color: #ffffff;
}

/* Formulaire de recherche (menu-bas) */

.formulaire_recherche
{
position: relative;
top: 9px;
left: 14px;
}

.formulaire_recherche_select
{
font-family: "Trebuchet MS", serif;
font-weight: bold;
font-size: 15px;
   	border: 2px solid #ffffff;
background-color: #000000;
color: #ffffff;
}

.formulaire_recherche_input
{
font-family: "Trebuchet MS", serif;
font-weight: bold;
font-size: 15px;
border: 2px solid #ffffff;
background-color: #000000;
color: #ffffff;
}

.formulaire_recherche_submit
{
font-family: "Trebuchet MS", serif;
font-weight: bold;
font-size: 15px;
}
Afficher la suite 

1 réponse

Meilleure réponse
Messages postés
31
Date d'inscription
jeudi 25 mars 2010
Statut
Membre
Dernière intervention
18 septembre 2010
1
3
Merci
bon j'ai vu où on était mon erreur, j'avais placé les "class" dans des balises entourant chaque élément de mon formulaire, alors que je devais simplement les mettre dans les balises sans utiliser de block !

Dire « Merci » 3

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

Codes Sources 197 internautes nous ont dit merci ce mois-ci

Commenter la réponse de BenamourJr