Envois E-Mail php

Signaler
Messages postés
3
Date d'inscription
mercredi 10 février 2010
Statut
Membre
Dernière intervention
12 février 2010
-
Messages postés
1654
Date d'inscription
dimanche 7 septembre 2008
Statut
Membre
Dernière intervention
11 septembre 2013
-
Bonsoir.
     <?php
      $msg = "Nom:\t$nom\n";
      $msg .= "Prenom:\t$prenom\n";
      $msg .= "Adresse:\t$adresse\n";
      $msg .= "Adresse2:\t$adresse2\n";
      $msg .= "Code_postal:\t$code_postal\n";
      $msg .= "Ville:\t$ville\n";
      $msg .= "E-Mail:\t$email\n";
      $msg .= "Naissance:\t$naissance\n";
      $msg .= "Options:\t$options\n\n";
      
     
      $recipient = ".....@orange.fr";
      $expediteur = ".....webou.net";
      $subject = "essais.php";
     
      $mailheaders = "From: Mon test de formulaire<> \n";
      $mailheaders .= "Reply-To: $email\n\n";
     
      mail($recipient, $subject, $msg, $mailheaders);
     
      echo "<HTML><HEAD>";
      echo "<TITLE>Formulaire envoyer!</TITLE></HEAD>";
      echo "Merci, $nom 
";
      echo "";
      echo "Votre formulaire à bien ete envoye !

";
      echo "</HTML>";
      ?>

Ce petit morceau de code (adapté de votre model.)Ne fonctionne pas .
SVP Auriez-vous une idée .
Ma page formulaire s'appelle essais.php elle contient nom prenom
Lorsque je clic j'obtiens le message de confirmation , mais ma boite réception reste vide .
Merci
Cordialement.

4 réponses

Messages postés
3
Date d'inscription
mercredi 10 février 2010
Statut
Membre
Dernière intervention
12 février 2010

Bonsoir.
Pas de couches tard connectés .
Je ne parviens pas à comprendre pourquoi ce petit morceau de code ne fonctionne pas ?
Au moins savoir pourquoi ..
C'est votre bébé .
Merci.
Cordialement.
Messages postés
21
Date d'inscription
jeudi 4 février 2010
Statut
Membre
Dernière intervention
30 août 2010

Bonjour,

ce bout de code fonctionne correctement. Peut-être que le problème vient de ton serveur:

- Est-ce que la fonction mail() est activée et configurée sur le serveur?
- Le script renvoi t'il un message d'erreur?


Tious
Messages postés
3
Date d'inscription
mercredi 10 février 2010
Statut
Membre
Dernière intervention
12 février 2010

Bonjour.
Merci.
Oui tout fonctionne sur le serveur .
Je cherche depuis ... même +
Cordialement.
Messages postés
1654
Date d'inscription
dimanche 7 septembre 2008
Statut
Membre
Dernière intervention
11 septembre 2013
20
Salut ton code fonctionne j ai essaye sous wamp,ovh,free ...


<?php
$nom="Dupont";
$prenom="stave";
$adresse="10 les Dupont";
$adresse2="sous les duponts";
$code_postal="78945";
$ville="Dupontville";
$email="Dupontmail@sdee.cxs";
$naissance="10-12-85";
$options="cool";

/////////////////////////////

$msg = "Nom:\t$nom\n";
$msg .= "Prenom:\t$prenom\n";
$msg .= "Adresse:\t$adresse\n";
$msg .= "Adresse2:\t$adresse2\n";
$msg .= "Code_postal:\t$code_postal\n";
$msg .= "Ville:\t$ville\n";
$msg .= "E-Mail:\t$email\n";
$msg .= "Naissance:\t$naissance\n";
$msg .= "Options:\t$options\n\n";


$recipient = "...@free.fr"; //ton mail
$expediteur = ".....webou.net";
$subject = "essais.php";

$mailheaders = "From: Mon test de formulaire<> \n";
$mailheaders .= "Reply-To: $email\n\n";

mail($recipient, $subject, $msg, $mailheaders);

echo "<HTML><HEAD>";
echo "<TITLE>Formulaire envoyer!</TITLE></HEAD>";
echo "Merci, $nom
";
echo "";
echo "Votre formulaire à bien ete envoye !

";
echo "</HTML>";
?>