Backkground Image LISTVIEW C#

maynalysa Messages postés 8 Date d'inscription mardi 15 décembre 2009 Statut Membre Dernière intervention 4 février 2010 - 3 févr. 2010 à 10:31
cs_coq Messages postés 6351 Date d'inscription samedi 1 juin 2002 Statut Membre Dernière intervention 2 août 2014 - 6 févr. 2010 à 15:01
Bonjour à tous,
J'ai un problème d'affichage des images de fond (BackgroundImage) de mes listsViews.
Lorsque le fenêtre contenant mes listviews est lancée en direct depuis le main, les images de fond s'affichent correctement. Mais lorsque cette fenêtre est lancée depuis une autre winform, les images de fond des listviews ne s'affichent pas.
Quelqu'un saurait pourquoi j'ai dysfonctionnement ?
Je précise que je crée manuellement les listviews, et que les images de fond sont situées dans le même répertoire que l'exécutable de mon logiciel.

Merci de votre attention et de votre aide.

3 réponses

cs_coq Messages postés 6351 Date d'inscription samedi 1 juin 2002 Statut Membre Dernière intervention 2 août 2014 100
3 févr. 2010 à 21:24
Bonjour,

Comment est chargée l'image de fond ?

/*
coq
MVP Visual C#
CoqBlog
*/
0
maynalysa Messages postés 8 Date d'inscription mardi 15 décembre 2009 Statut Membre Dernière intervention 4 février 2010
4 févr. 2010 à 15:00
Les images sont chargée de la façon suivante:

listViewAnnuaire.BackgroundImage = new System.Drawing.Bitmap("annuaire4.jpg");
0
cs_coq Messages postés 6351 Date d'inscription samedi 1 juin 2002 Statut Membre Dernière intervention 2 août 2014 100
6 févr. 2010 à 15:01
Avec chemin relatif donc.

En dehors de l'affectation au contrôle, l'image se charge bien ?


/*
coq
MVP Visual C#
CoqBlog
*/
0
Rejoignez-nous