VBS IE Navigate [Résolu]

Signaler
Messages postés
158
Date d'inscription
dimanche 18 avril 2004
Statut
Membre
Dernière intervention
25 juillet 2018
-
Guillamue06
Messages postés
158
Date d'inscription
dimanche 18 avril 2004
Statut
Membre
Dernière intervention
25 juillet 2018
-
Bonjour à tous,

J'ai un problème avec la fonction navigate de l'objet InternetExplorer.Application en VBS :

dim IE
Set IE = CreateObject("InternetExplorer.Application")

IE.Navigate = ("http://www.google.fr")


A l'ouverture de mon scrip jai l'erreur suivante :
Cet objet ne gère pas cette propriété ou cette méthode "Navigate"

800A01B6

3 réponses

Messages postés
158
Date d'inscription
dimanche 18 avril 2004
Statut
Membre
Dernière intervention
25 juillet 2018
3
Re, je vien de trouver le truc finalement :

IE.navigate = "http://www.google.fr"

c'est le "=" qui vas pas et avec ou sans WScript sa fonctionne.

Cordialement
Messages postés
1854
Date d'inscription
jeudi 23 mai 2002
Statut
Membre
Dernière intervention
24 juin 2018
25
 Bonsoir,

Utilise le wsh
Set oIE = WScript.CreateObject("InternetExplorer.Application", "IE_")
oIE.navigate "http://www.google.fr"
oIE.Visible = 2


http://technet.microsoft.com/en-us/library/ee176573.aspx


jean-marc
Messages postés
158
Date d'inscription
dimanche 18 avril 2004
Statut
Membre
Dernière intervention
25 juillet 2018
3
Merci, après mon premier post j'ai testé sur un autre Pc (Win7) sans le WScript et sa fonctionne mais pas sur celui la...

le: , "IE_" je ne vois pas à quoi il sert car avec ou sans cela fonctionne.

Cordialement