Pb lecture page internet avec Vista et VB

Signaler
Messages postés
5
Date d'inscription
lundi 1 août 2005
Statut
Membre
Dernière intervention
4 janvier 2016
-
Messages postés
5
Date d'inscription
lundi 1 août 2005
Statut
Membre
Dernière intervention
4 janvier 2016
-
Bonjour a tous,

J'ai une application Excel VB qui tournait très bien sur mon ancien micro avec IE7 et Windows XP. Ce programme allait lire des pages internet sans les afficher et en extrayait des données. J'ai changé de micro et maintenant je tourne sous Windows Vista et IE7 et quand je lance mon programme VB, il va lire une première page internet qu'il affiche et ensuite le programme plante avec le message ?problème lecture page internet () erreur automation. L'objet invoqué s'est déconnecté de ses clients?.

J'ai demandé a un copain de faire tourner mon application sur son micro qui a également Vista et IE7 et ca marche bien. Quelqu'un peut-il m?aider a résoudre ce problème qui commence a bien me prendre la tete.

Voici le code mais ca ne vient pas de la.

Set IE = CreateObject("InternetExplorer.Application")
IE.navigate adresse
Do Until IE.ReadyState = READYSTATE_COMPLETE
DoEvents
Loop 'attend la fin du chargement
Set doc1 = IE.document
ch1 = doc1.body.innerHTML

Merci d'avance.
grosminet

2 réponses

Messages postés
1241
Date d'inscription
mardi 10 octobre 2006
Statut
Membre
Dernière intervention
27 août 2013
4
Bonjout,

Tu parles d'une application Excel vb, mais qu'entends-tu par là?
Le vb de excel donc vba?
Ou bien tu pilotes excel via vb.net?

Car cela n'est pas la même chose.
Si excel, as-tu la même version?
Si c'est un programme vb.net, comment as tu réalisé le package d'installation pour créer l'exe??

sur ton vista, as-tu installé des mises à jour(dll, ocx...) que ton copain n'aurait pas effectuées?

L'expérience, c'est une connerie par jour, mais jamais la même..
Messages postés
5
Date d'inscription
lundi 1 août 2005
Statut
Membre
Dernière intervention
4 janvier 2016

Bonjour lolokun,

Merci de m'avoir repondu mais j'ai trouvé la reponse. Il s'agissait juste de desactiver le mode protégé et de mettre le filtre antihameconnage.