Calcul somme selon critères

Signaler
Messages postés
18
Date d'inscription
jeudi 16 juillet 2009
Statut
Membre
Dernière intervention
28 août 2009
-
Messages postés
298
Date d'inscription
jeudi 22 janvier 2009
Statut
Membre
Dernière intervention
26 septembre 2009
-
Bonjour,

J'ai les données suivantes :

col A col B

USA 10
latin america 20
japan 30
UK 10
North america 50
Asia, japan 40

je voudrais faire la somme des éléments de la colonne B sous certaines conditions :

- additionner tous les nombres de la colonne B pour toutes les lignes qui contiennent les termes "USA" ou "North America". ici la macro retournera le résultat "10+50"
- additionner les nombres de la colonne B pour toutes les lignes qui contiennent les termes "Japan". dans l'exemple, ma macro devra donc retourner le résultat de "30+40"

6 réponses

Messages postés
672
Date d'inscription
mercredi 22 janvier 2003
Statut
Membre
Dernière intervention
2 juin 2016
1
Bonjour

Je crois que c'est encore moi juanito37
Pour faire comprendre que USA fait partie du continent North america et que japan fait partie du continent asiatique (soit Asia), il faut faire un onglet "CONTINENT" avec deux colonnes , Contient et Pays et répéter peut être dans la colonne pays le continent

Pour le reste dans Excel , utiliser la fonction RECHERCHEV pour l'onglet CONTINENT, et la fonction du menu "Données/Rupture" dans Excel?
Messages postés
672
Date d'inscription
mercredi 22 janvier 2003
Statut
Membre
Dernière intervention
2 juin 2016
1
L'onglet CONTINENT devra être trié sur les 2 colonnes à la Fois

La fonction "Données/Rupture" permet de faire des sommes sur la rupture, pour cela effectivement sur la feuille de calcul , il faudra créer une troisième colonne que j'appelerai le "continent correspondant au pays" sur laquelle il faudra coller la formule "=RECHERCHEV(A1,"CONTINENT!$A$1:$B$10000;2;FAUX)
Messages postés
18
Date d'inscription
jeudi 16 juillet 2009
Statut
Membre
Dernière intervention
28 août 2009

on ne peut donc faire une somme d'éléments sous condition critère est contenu dans une cellule

dans mon cas additionner directement toutes les valeurs de ma colonne B si un mot clé est contenu dans une autre colonne A
Messages postés
672
Date d'inscription
mercredi 22 janvier 2003
Statut
Membre
Dernière intervention
2 juin 2016
1
Il faut utiliser sucessivement plusieurs fonctions
On peut peu-etre abandonner RECHERCHEV

Et choisir SOMME.SI et CHERCHE en les imbriqaunt

SOMME.SI(Cnd;Retour Cnd Vraie;Retour condition fausse)
CHERCHE(A1;"Asia") retourne l'index dans la chaine A1 si Asia est trouvé sinon 0
Messages postés
672
Date d'inscription
mercredi 22 janvier 2003
Statut
Membre
Dernière intervention
2 juin 2016
1
Il y a Plus simple que je ne l'aurais imaginé

=SOMME.SI(A1:A1000;"Asia":B1:B1000)
=SOMME.SI(A1:A1000;"USA":B1:B1000)+ SOMME.SI(A1:A1000;"North America":B1:B1000)
Messages postés
298
Date d'inscription
jeudi 22 janvier 2009
Statut
Membre
Dernière intervention
26 septembre 2009

Bonjour à tous,

Et la fonction Split ?