Comment activer l'authentification windows intégrée?

Résolu
cs_papiras Messages postés 11 Date d'inscription lundi 10 décembre 2007 Statut Membre Dernière intervention 27 juillet 2009 - 10 juil. 2009 à 10:29
cs_papiras Messages postés 11 Date d'inscription lundi 10 décembre 2007 Statut Membre Dernière intervention 27 juillet 2009 - 13 juil. 2009 à 12:40
Bjr,<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" /??>



 




Je suis en train de développer une appli web en asp.net en tant que débutante.


(Je travaille avec Vista, C# sous Visual Studio 2005, IE7).



<li>
Dans IE, "Activer l’authentification Windows intégrée" est activé
</li>
<li>

Dans le fichier web.config ==>

</li>
<li>


Dans IIS "Authentification Windows" est activée (voir image ci-desous)


</li>









Mais en lançant le débogage, j’obtiens l’erreur suivante :









"Impossible de démarrer le débogage sur le serveur Web. Le débogage a échoué, car l’authentification Windows intégrée n’est pas activée. Consulter l’aide pour plus d’informations"




 




Quelle paramettrage je dois encore faire pour résoudre ce problème?



 




Merci 
 


PS: Quelqu'un pourrait-il me conseiller un meilleur ébergeur d'image (gratuit)? J'utilise "http://www.zimagez.com" avec lequel l'image n'est pas suffisament clair comme vous le constatez ou bien c moi qui paramettre mal l'image?


 

6 réponses

jesusonline Messages postés 6814 Date d'inscription dimanche 15 décembre 2002 Statut Membre Dernière intervention 13 octobre 2010 29
11 juil. 2009 à 02:00
Bonjour,

Ce que tu montres est un IIS6, rien à voir avec IIS7. Avec IIS7, il faut aller dans la catégorie IIS puis Authentication et activé l'authentification windows. Si tu utilises cassini (le mini serveur web intégré dans Visual Studio) il me semble que tu as une option dans les propriété du projet à cocher/décocher afin de prendre ou non en compte l'authentification NTLM.

<hr />Cyril - MVP ASP.net - MCPD ASP.net & MCTS SQL - Consultant indépendant
3
cs_ghuysmans99 Messages postés 3983 Date d'inscription jeudi 14 juillet 2005 Statut Membre Dernière intervention 30 juin 2013 16
10 juil. 2009 à 11:38
Dans IIS, propriétés du site web, Sécurité, Accès anonyme...
0
cs_ghuysmans99 Messages postés 3983 Date d'inscription jeudi 14 juillet 2005 Statut Membre Dernière intervention 30 juin 2013 16
10 juil. 2009 à 11:45
En ce qui concerne ton hébergement d'images, tu as utilisé la miniature au lieu de l'image elle-même ...
0
cs_papiras Messages postés 11 Date d'inscription lundi 10 décembre 2007 Statut Membre Dernière intervention 27 juillet 2009 1
10 juil. 2009 à 19:29
IIS Sous Vista n'a pas d'option "accés anonyme..".
Voici les seuls options présentes sous "Sécurité" dans IIS:

1-Authentification de base
2-Authentification Digest
3-Authentification par mappage de certificat client
4-Authentification par mappage de certificat client IIS
5-Authentification Windows (activé)
6-Authentification d'URL (activé)
7-Filtrage des demandes (activé)
8-Sécurité IP
   
En ce qui concerne l'ébergement de l'image, j'ai effectivement utilisé la miniature. Mais l'autre possibilité était "avatar" qui présente l'image sous une forme plus petite que sous miniature...

Merci
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
cs_ghuysmans99 Messages postés 3983 Date d'inscription jeudi 14 juillet 2005 Statut Membre Dernière intervention 30 juin 2013 16
10 juil. 2009 à 23:57
Tu regardes pas dans la bonne interface ...
Tu devrais voir quelque chose comme ça :
0
cs_papiras Messages postés 11 Date d'inscription lundi 10 décembre 2007 Statut Membre Dernière intervention 27 juillet 2009 1
13 juil. 2009 à 12:40
Merci à vous,
c'était là mon problème. Je ne regardais pas dans la bonne interface. Je suis allé ds la catégorie IIS et j'ai activé l'authentification windows et tout a bien marché.

Merci une fois de plus.
papiras
0