Probleme mis à jour identifiant

Signaler
Messages postés
12
Date d'inscription
lundi 2 mars 2009
Statut
Membre
Dernière intervention
19 mars 2009
-
Messages postés
12
Date d'inscription
lundi 2 mars 2009
Statut
Membre
Dernière intervention
19 mars 2009
-
bonjour,


Une video vaut mieux qu'un long discours,
c'est en anglais mais ce qui importe c'est les images principalement
http://msdn.microsoft.com/en-us/vbasic/bb643827.aspx
Je suis dans le même cas de figure, le problème est que lorsque j'ajoute un nouveau customer ca me met -1,  et dans l'order que j'édite, customerID=-1 est reste à-1 même après l'enregistrement, alors que customerID passe de -1 à une autre valeur.
Quelqu'un aurait-il une idée sur comment procéder?


merci

2 réponses

Messages postés
17286
Date d'inscription
mercredi 2 janvier 2002
Statut
Modérateur
Dernière intervention
23 décembre 2019
68
j'espere que cette video restera en ligne, sinon on ne pourra rien comprendre a ton probleme.

moi même, qui du boulot ne peux lire les videos....
Messages postés
12
Date d'inscription
lundi 2 mars 2009
Statut
Membre
Dernière intervention
19 mars 2009

Je pense qu'elle restera en ligne, c'est une video microsoft.
Pour résumer, mon problème est que lorsque j'ajoute un enregistrement à une table, l'auto customerID se met à -1 et dans la table lié order customerID se met également à -1, mais lorsque j'enregistre, cette ID passe à une autre valeur dans la table customer, mais pas dans la table order.
Je sais pas si je suis assez clair...