éléments qui disparaissent lors insertion jscript

Signaler
Messages postés
44
Date d'inscription
vendredi 23 mai 2008
Statut
Membre
Dernière intervention
25 décembre 2009
-
Messages postés
1251
Date d'inscription
mercredi 7 août 2002
Statut
Modérateur
Dernière intervention
10 avril 2013
-
Bonjour,

j'espère que vous pourrez me venir en aide. En effet, à chaque fois
que j'insère par exemple un tableau fonctionnant avec du Jscript ou une
boite de liste dans une de mes pages html, une partie de ma page
disparait, le code reste inchangé et l'affichage dans mes navigateurs
est ok. Je ne peux donc plus modifier certains éléments de la page en
mode création. Peut être, faut il insérer des balises particulière.

j'utilise dreamweaver cs3

merci de l'attention que vous voudrez bien porter à ce message

6 réponses

Messages postés
13616
Date d'inscription
jeudi 13 février 2003
Statut
Membre
Dernière intervention
15 octobre 2013
33
Bonjour,
    >>à chaque fois que j'insère
    mais encore ?   avec dreamweaver ?   dans la source ?
       en dynamique avec javascript ( ou autres )    ?
<hr />                Cordialement            Bul         [mon Site]     [M'écrire]
Messages postés
44
Date d'inscription
vendredi 23 mai 2008
Statut
Membre
Dernière intervention
25 décembre 2009

oui c'est bien avec dreamweaver, en copiant le code et en l'insérant dans le code (avec ou sans fichier xml c'est pareil)
Messages postés
13616
Date d'inscription
jeudi 13 février 2003
Statut
Membre
Dernière intervention
15 octobre 2013
33
alors... si je comprend bien ! mais je ne suis pas sûr quand
    tu parles de fichier xml !   tu dois faire une "fausse manip"
    je ne sais où, mais comme je ne connais pas du tout dreamweaver
    je ne vais guère pouvoir t'aider beaucoup plus....
<hr />                Cordialement            Bul         [mon Site]     [M'écrire]
Messages postés
1251
Date d'inscription
mercredi 7 août 2002
Statut
Modérateur
Dernière intervention
10 avril 2013

Attention sous DW il faut faire le coller en vue code et non en vue design !
En vue design, ton code devient du contenu !

Nickadele
Messages postés
44
Date d'inscription
vendredi 23 mai 2008
Statut
Membre
Dernière intervention
25 décembre 2009

je le colle bien en mode code mais par la suite comme je l'ai dit plus haut l'affichage de ma page en mode design est complètement modifié avec disparition de certains éléments comme des tables. Tout apparait normalement dans les navigateur, tout est bien present
Messages postés
1251
Date d'inscription
mercredi 7 août 2002
Statut
Modérateur
Dernière intervention
10 avril 2013

DW interprete parfois mal le css. C'est bien possible que sous DW ton affichage ne ressemble à rien et que sous un browser tout est ok !