Problème onmouseover

Signaler
Messages postés
151
Date d'inscription
jeudi 23 décembre 2004
Statut
Membre
Dernière intervention
20 décembre 2012
-
Messages postés
13616
Date d'inscription
jeudi 13 février 2003
Statut
Membre
Dernière intervention
15 octobre 2013
-
bonjour
j'ai un petit problème avec mon onmouseover

voici mon code
[blabla.html Le journal
 du député]


en faite ça ne me mets pas, au passage du curseur, le changement de couleur du lien

et en bas de ma page web, j'ai "done but with errors on page"


 


et je en comprends pas pourquoi


 


pouvez vous m'aider?
merci d'avance

5 réponses

Messages postés
13616
Date d'inscription
jeudi 13 février 2003
Statut
Membre
Dernière intervention
15 octobre 2013
33
Bonjour,

mon Site]     [M'écrire]
Messages postés
469
Date d'inscription
mercredi 9 janvier 2002
Statut
Membre
Dernière intervention
20 février 2017
5
Bonjour aussi, y a encore plus simple et sans javascript :
<html>
    <head>
        <title>
        </title>
        <style>
    .RedOver:hover{
       color:red;
    }
    </style>

    </head>
   
    [blabla.html Le journal
du député]
   
</html>

hé hop !
attention cela ne fonctionne que sur la balise A (en tout cas pour ie)
[o-_-o]
Messages postés
13616
Date d'inscription
jeudi 13 février 2003
Statut
Membre
Dernière intervention
15 octobre 2013
33
Bonjour,

    c'est vrai zobibol !
    et ça marche pour IE comme avec FF si on met le doctype qui va bien

    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
        "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
         
<hr />                Cordialement            Bul         [mon Site]     [M'écrire]
Messages postés
469
Date d'inscription
mercredi 9 janvier 2002
Statut
Membre
Dernière intervention
20 février 2017
5
Mais c'est qu'aujourd'hui je suis à 200%...
je viens de supprimer le message que j'écrivais.
Allez rebelotte :

<html>
    <head>
        <title>
        </title>
        <style>
    .TexteBleuLeft_Bold14:hover{
       color:red;
    }
   
    </style>

    </head>
   
    [blabla.html Le journal
du député]
   
</html>

la classe RedOver n'a strictement pas lieu d'être, je n'avais pas vu l'attribut class sur la balise ...

[o-_-o]
Messages postés
13616
Date d'inscription
jeudi 13 février 2003
Statut
Membre
Dernière intervention
15 octobre 2013
33
je n'avais mêm pas remarqué....
    et si ça se trouve, peut-être aucune classe ?

<style>
    a             {   color:blue;   }
    a:hover   {   color:red;   }
</style>
[blabla.html Le journal
du député]

<hr />                Cordialement            Bul         [mon Site]     [M'écrire]