Problème d'affichage dans l'éditeur [Résolu]

mike_vk 30 Messages postés dimanche 5 mars 2006Date d'inscription 13 septembre 2013 Dernière intervention - 25 avril 2008 à 15:55 - Dernière réponse : mike_vk 30 Messages postés dimanche 5 mars 2006Date d'inscription 13 septembre 2013 Dernière intervention
- 26 avril 2008 à 15:50
Bonjour,

J'ai un petit problème d'affichage dans l'éditeur, comme si le repaint() du compilateur lui-même foirait.
Quand j'ouvre une fenetre de code (.prg par exemple) et que je la mets en "plein écran" (donc taille max de la fenetre de code), certaines lignes apparaissent toutes noires!
Si je scrolle vers le bas afin qu'une de ces lignes ne soit plus visible, puis que je remonte, elle réapparrait normale...

Ca doit paraitre bizarre, expliqué comme ça, mais j'ai encore d'autres petits bugs, par exemple de temps en temps, un item d'un menu contextuel est tout noir! ou bien lorsque je repasse du "plein écran" en "fenêtre", tout le code reste dans le _screen, il faut que je passe ma fenetre de code partout pour "gommer" ce code.

Je suis certain que c'est un problème de repaint. J'ai réinstallé Visual Foxpro ET son SP2, rien n'y change. Je suis à jour au niveau de mon pilote d'affichage... je n'ai plus d'idée. J'ai cru voir un jour qu'il était possible de modifier la façon dont Visual Foxpro bufferait son affichage, mais je ne retrouve plus comment. Dans le config.fpw ?

Quelqu'un sait m'aider ?? Un grand merci d'avance,

Mic
Afficher la suite 

Votre réponse

6 réponses

Mike Gagnon 381 Messages postés vendredi 15 octobre 2004Date d'inscription 24 octobre 2013 Dernière intervention - 26 avril 2008 à 13:50
+3
Utile
Le seul probème que je peux voir est un problème d'une carte vidéo déffecteuse (et non le pilote). Rien avoir avec Repaint()

Mike Gagnon
Cette réponse vous a-t-elle aidé ?  
Commenter la réponse de Mike Gagnon
Mike Gagnon 381 Messages postés vendredi 15 octobre 2004Date d'inscription 24 octobre 2013 Dernière intervention - 26 avril 2008 à 15:28
+3
Utile
Milles excuse, la solution possible est:
BITMAP =OFF


Au lieu de

PAINT = OFF

Mike Gagnon
Cette réponse vous a-t-elle aidé ?  
Commenter la réponse de Mike Gagnon
mike_vk 30 Messages postés dimanche 5 mars 2006Date d'inscription 13 septembre 2013 Dernière intervention - 26 avril 2008 à 14:29
0
Utile
Mmmh, merci...

J'ai oublié de préciser que je viens de formater mon portable, et que je n'avais pas le problème avant. J'ai pourtant réinstallé les derniers pilotes de la carte vidéo... elle serait donc défectueuse ? :-(
Existe-t-il quelque part une liste exhaustive (ou non) des paramètres que l'on peut mettre dans le config.fpw ? Je suis quand même interressé de retrouver cette histoire de buffer d'affichage, ça peut toujours servir! J'ai cherché pas mal, mais n'ai trouvé qu'un site donnant un liste très restreinte.

Encore merci pour ta présence continue sur ces forums!
Vive foxpro ;-)

Mic
Commenter la réponse de mike_vk
Mike Gagnon 381 Messages postés vendredi 15 octobre 2004Date d'inscription 24 octobre 2013 Dernière intervention - 26 avril 2008 à 14:49
0
Utile
Il existait un problème avec Citrix Metaframe et le Paint. Si je ve souviens bien la solution était de mettre PAINT = OFF dans la config, mais je ne suis pas sur que cela va aider.

Mike Gagnon
Commenter la réponse de Mike Gagnon
mike_vk 30 Messages postés dimanche 5 mars 2006Date d'inscription 13 septembre 2013 Dernière intervention - 26 avril 2008 à 14:52
0
Utile
Merci !
Commenter la réponse de mike_vk
mike_vk 30 Messages postés dimanche 5 mars 2006Date d'inscription 13 septembre 2013 Dernière intervention - 26 avril 2008 à 15:50
0
Utile
Haha, ok, ça j'avais déjà essayé, ça ne change rien...
Merci quand même !
Commenter la réponse de mike_vk

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes et codes sources.

Le fait d'être membre vous permet d'avoir des options supplémentaires.