Dreamweaver et swf chargeant un xml

Résolu
Signaler
Messages postés
2
Date d'inscription
lundi 11 septembre 2006
Statut
Membre
Dernière intervention
18 février 2007
-
Messages postés
21
Date d'inscription
mercredi 30 mai 2007
Statut
Membre
Dernière intervention
27 décembre 2008
-
Bonjour a tous

J'ai un soucis sur l'integration d'un swf chargeant un xml.
Le swf compilé fonctionne parfaitement bien puis des que je le place
sur une page html, pas moyen de voir quelque chose.
En fait c'est comme si il ne chargeait pas le fichier xml!!!

Une petite idée???

9 réponses

Messages postés
6146
Date d'inscription
dimanche 21 décembre 2003
Statut
Modérateur
Dernière intervention
4 septembre 2013
10
Salut

Tu es au courant que l'adresse de chargement de ton XML doit être référent à ta page HTML et pas à l'endroit où se trouve ton Fichier SWF ?

Peg'
Messages postés
2
Date d'inscription
lundi 11 septembre 2006
Statut
Membre
Dernière intervention
18 février 2007

Merci beaucoup a toi

A+
Messages postés
21
Date d'inscription
mercredi 30 mai 2007
Statut
Membre
Dernière intervention
27 décembre 2008

Bonjour pegase,

 Je suis débutante et le dévoleppeur étant absent, j'ai le même problème que chrisparelon, sauf que moi je ne sais pas quel code mettre dans le html pour que mon xml se charge... Pourrais-tu m'aider?
Merci
Messages postés
6146
Date d'inscription
dimanche 21 décembre 2003
Statut
Modérateur
Dernière intervention
4 septembre 2013
10
ce n'ets pas le html qui charge le xml .. mais Flash ...

Peg'
Messages postés
21
Date d'inscription
mercredi 30 mai 2007
Statut
Membre
Dernière intervention
27 décembre 2008

Oui oui je sais bien mais il faut bien "rescencer" le fichier xml dans la page html, vu que j'ai intégré mon swf dans cette page html... non? Moi je suis les directives du développeur après tout....
Messages postés
6146
Date d'inscription
dimanche 21 décembre 2003
Statut
Modérateur
Dernière intervention
4 septembre 2013
10
heu ... le xml n'a aucun rapport avec html. Pourquoi veux-tu "recenser" ton xml ?

Peg'
Messages postés
21
Date d'inscription
mercredi 30 mai 2007
Statut
Membre
Dernière intervention
27 décembre 2008

Bon j'ai peut être mal compris alors... Je pense que je m'explique mal. Je récapitule; J'ai  créer un diaporama flash, avec un  fichier xml lié, j'ai ensuite intégrer le swf de ce diapo dans un autre élément flash, disons fiche.fla. J'ai intégrer le fiche.swf dans une page html,  il se charge correctement, mais pas le diaporama.swf que j'avais alors importer dans fiche.swf. Du coup, lorsque je publie ma page html, fiche.swf se charge bien, mais pas diapo.swf. Donc je croyais que c'était dû au fait que je n'avais pas rescencé le fichier lié xml dans ma page html. Voilà. En fait, je ne suppose qu'il faut mettre le xml au même niveau que ma page html, je ne sais plus comment faire...
Messages postés
6146
Date d'inscription
dimanche 21 décembre 2003
Statut
Modérateur
Dernière intervention
4 septembre 2013
10
quand tu charges un fichier swf dans un htmi, tu dois charger le xml dans le flash avec l'adresse de référence par rapport au html :

si tu as :
index.html
images/anim.swf
data/data.xml

l'adresse de chargement de ton xml devra être "data/data.xml" et pas "../data/data.xml". tu saisis ?

Pareil si tu as :
index.html

images1/anim1.swf

images1/anim/anim2.swf

data/data.xml

Si le html contiens anim1 et que ce dernier charge anim2, si anim2 charge le xml, l'adresse sera "data/data.xml" et pas "../../data.data.xml"

tu saisis ?

Peg'
Messages postés
21
Date d'inscription
mercredi 30 mai 2007
Statut
Membre
Dernière intervention
27 décembre 2008

Ok ok merci beaucoup^^ Tu me retire une épine du pied^^