Problème avec une boucle for, DE L'AIDE SVP

Résolu
Messages postés
21
Date d'inscription
lundi 7 juin 2004
Statut
Membre
Dernière intervention
19 janvier 2007
-
Messages postés
21
Date d'inscription
lundi 7 juin 2004
Statut
Membre
Dernière intervention
19 janvier 2007
-
Bonjour à tous,

J'essaye de faire une bannière dont tous les fichiers sont appelé depuis l'extérieur, j'ai fait un code qui permet via les variable de tout automatiser, fin je suis débutant donc peut être que ce n'ai pas top top

Le code est modifier pour fonctionner dans un éditeur professionnel de site Internet, le problème c'est qu'en local tout fonctionne bien, mais en ligne j'ai la dernière image, donc le calque sensé apparaître en dernier qui apparaît et c'est tout, donc tout ce qui est anim ne fonctionne plus.

Je pense que l'eereur vient de la boucle for mais je n'en suis pas sûr

Si l'une des bonne âme de ce forum peut venir à mon secour se serait génial.

voici le code utilisé :

stop();
/*chemin d'accès rélatif vers le dossier contenant les resources*/
/*path = "folder_name/folder_name/";*/
var path = "";
/*nom du fichier Flash (sans extension)*/
/*name = "file_name";*/
var name = "banner";




/*nombre d'images utilisées dans la séquence*/
var numPictures = 4;


/*Code permettant au SWF de trouver les img et txt sur un serveur*/
//getURL("javascript:getFlashresources("+path+name+")");


/*Code permettant d'afficher la deuxième ligne de texte*/
loadVariablesNum(path+name+".txt", 0);
system.usecodepage=true;

for(i=0; i<numPictures; i++) { 
    var resourceIndex = (i+1);
    var clipName = "Clip_" + resourceIndex;
    var pictName = path + name + resourceIndex + ".jpg";
 var empty = this.createEmptyMovieClip( clipname, _this.getNextHighestDepth());
    var loadmovie = loadMovie( pictName, clipName);
}


/*Code permettant d'activer le lien de la bannière (lien attribué depuis l'editeur clicktoweb)*/
function getLink () {
 getURL("javascript:getFlashlink("+path+name+")");
}


music = new Sound();
music.loadSound(path+name+".mp3", true);
function musicplay() {
music.loadSound(path+name+".mp3", true);
}
music.start();

2 réponses

Messages postés
21
Date d'inscription
lundi 7 juin 2004
Statut
Membre
Dernière intervention
19 janvier 2007

Problème résolu, c'est le stop(); qui fesait tout planter.

Merci quand même.
Messages postés
21
Date d'inscription
lundi 7 juin 2004
Statut
Membre
Dernière intervention
19 janvier 2007

PS : J'ai l'impression qu'avec cette boucle, l'image appelée et mise directement en premier plan, c'est peut être la raison pour laquelle tout ce qui est animation n'apparaît pas.

Fin j'espère que vous pourrez m'aider.

++

Max