IIS connecter un serveur local pour ASP 2 vers sql server 2005 [Résolu]

Signaler
Messages postés
36
Date d'inscription
jeudi 7 juillet 2005
Statut
Membre
Dernière intervention
2 octobre 2008
-
Messages postés
36
Date d'inscription
jeudi 7 juillet 2005
Statut
Membre
Dernière intervention
2 octobre 2008
-
Salut,

Est ce quelqu'un pourrait m'aiguiller sur la "Metabase" de IIS pour ASp.net 2.0 .(un tutorial, une source, une tite explication, n'importe koi autre que la page de mon message d'erreur ci dessous.

Mon site marche nickel(saise de données, etc..) quand je fait "Voir dans l'explorateur" de VS2005. Mais d'un répertoire virtuel, j'arrive toujours sur
Server Error in '/test' Application.
<HR width= "100%" color=silver SIZE=1>


Failed to access IIS metabase.
Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.Web.Hosting.HostingEnvironmentException: Failed to access IIS metabase.

The process account used to run ASP.NET must have read access to the IIS metabase (e.g. IIS://servername/W3SVC). For information on modifying metabase permissions, please see =267904 http://support.microsoft.com/?kbid=267904.

Bon j'ai mis tout le message d'erreur. J'ai bien essayé de suivre Msdn et d'exécuter le .vbs fournit par Ms. Mais aucun résultat , ni aucune piste ne met venue alors au bout d'une semaine de bloquage, je fait appel a l'expérience de ASP.fr.

Je pense que toute personne ayant déja fait une mise en prod sur IIS devrait savoir faire...alors si il pouvait me rendre ce petit coup de pouce ce serait super cool.

Merci d'avance


MOOKIES

2 réponses

Messages postés
6814
Date d'inscription
dimanche 15 décembre 2002
Statut
Modérateur
Dernière intervention
13 octobre 2010
27
bonjour,

rééssaye d'installer IIS puis d'installer .net (désinstalle tout avant :s)


<HR>
Cyril - MVS - MCP
Messages postés
36
Date d'inscription
jeudi 7 juillet 2005
Statut
Membre
Dernière intervention
2 octobre 2008

Merci Cyril c'était exactement sa le Pb. J'ai fait aspnet_regiis.exe _i dans le répertoire du framework aproprié et SA MARCHE !!

Enfin presque, mes connections qui marche en le lançant avec VS2005 qui ouvre un port...
Mais les connections ne marche pas avec le répertoire virtuel. J'ai bien mis JB/ASPNET comme utilisateur anonymes dans IIS. J'ai coupé les firewall.
Et on m'a dis (voir [forum.v2.aspx?ID= 711955 http://www.aspfr.com/forum.v2<wbr>.aspx?ID=711955 )]
d'insérer la ligne de commande :

Et j'utilise les connections suivantes:




Et avant de mettre la ligne de commande "",
Lors que je me logguait il écrivait JB/ASPNET n'a pas les droit, dans un beau message d'erreur serveur

Maintenant il met juste Connexion non établit dans le controle loginview (qui tape dans la base aspnetdb.mdf . Je joue depuis ce matin avec les connexions mais rien à faire...

Dois je donner des droit en lecture à JB/ASPNET dans SQLserver?
Mes chaines de connexion sont ils correct pour utiliser users et rôles dans la base
aspnetdb de sorte à pouvoir utiliser quelque chose de style:

<location path ="Admin">
<system.web>


<deny users="*"/>

</system.web>
</location>
<location path="Users">
<system.web>


<deny users="*"/>

</system.web>
</location>

ET encore et encore MERCI CODES-SCOURCES

MOOKIES