Vidéo!!!

Signaler
Messages postés
98
Date d'inscription
samedi 17 septembre 2005
Statut
Membre
Dernière intervention
24 mai 2010
-
Messages postés
98
Date d'inscription
samedi 17 septembre 2005
Statut
Membre
Dernière intervention
24 mai 2010
-
Bonjour ;



J'ai créé une forme non rectangulaire en appliquant un Skin, donc une image bmp . Je voulais ajouter un groupBox ou un panel où afficher la vidéo de la Webcam... Et là mon problème .
J'ai le vidéo de la Webcam affichée mais elle n'est pas stable...
Apparemment c'est dû au raffraîchissement de OnPaint qui redessine à
chaque fois la forme et cache la vidéo pour une fraction de seconde
pour redessiner la vidéo après et là j'ai un clignottement de la
vidéo... Enfin je pense !!!



Quelqu'un pourrait m'orienter pour avoir la vidéo stable, sachant que j'ai pas ce problème avec une Winform normale!!!



Merci

3 réponses

Messages postés
4936
Date d'inscription
lundi 17 février 2003
Statut
Modérateur
Dernière intervention
14 février 2014
36
aurais-tu mis un fond transparent à ton panel ?

si oui.... retire le. je pense que ca règlera ton problème.

Sébastien FERRAND
[MVP C#]
Messages postés
98
Date d'inscription
samedi 17 septembre 2005
Statut
Membre
Dernière intervention
24 mai 2010
1
Justement... Le fond du panel n'est pas transparent
!!! J'ai essayé avec un panel transparent et non transparent ... Le
problème est toujours pareil !!!



Je suis en train de voir de mon côté... S'il y a quelquechose, je vous ferai signe !!!



En attendant, ya-t-il une autre astuce ?
Messages postés
98
Date d'inscription
samedi 17 septembre 2005
Statut
Membre
Dernière intervention
24 mai 2010
1
Bingo... J'ai résolu le problème... Mais j'ai pas
compris pourkoi!!! J'ai simplement changé le Backround du Panel
par noir, et plus de clignottement de la Vidéo !!!



Mais là, j'ai un autre problème!!! Pour ne pas déssiner la fome carrée, juste l'image du Skin, j'ai mis :

this.TransparencyKey = Color.Black ;

Là, j'ai la transparence mais pas en déplaçant la fome... j'ai la trace de la forme dans le cadre réservée à la forme !!!



Aussi, j'ai la trace de la vidéo en déplaçant l'application, sur toute la surface de l'écran !!!



Est-ce ue quelqu'un peut m'aider ????