Pb lors de réception de mail envoyés par php : l'image n'apparait pas [Résolu]

Signaler
Messages postés
92
Date d'inscription
mercredi 28 janvier 2004
Statut
Membre
Dernière intervention
2 octobre 2006
-
Messages postés
87
Date d'inscription
vendredi 29 août 2003
Statut
Membre
Dernière intervention
19 mai 2006
-
Bonjour à tous
Voilà, mon problème c'est que lorsque je veux envoyer un mail avec une image, l'image n'apparait pas à la réception du mail.
il y a la case pour l'image mais elle n'est pas dedans.
Quelqu'un aurait il une idée d'où ca peut venir ?
Voici le code envoyé :

$entete = "From: "$nomloc" <$nomloc>\n";
$entete .= "X-Sender: <$nomloc>\n";
$entete .= "X-Mailer: PHP\n";
$entete .= "X-Priority: 1\n";
$entete .= "Return-Path: <$nomloc>\n";
$entete .= "Content-Type: text/html; charset=iso-8859-1\n";

mail("$dest","$sujet","$message","$entete");

merci d'avance

CB

1 réponse

Messages postés
87
Date d'inscription
vendredi 29 août 2003
Statut
Membre
Dernière intervention
19 mai 2006

Deux choix,

le premier tu envoi ton image en fichier joint, ou tu envoi ton image code64 (codée en lignes de 64 caracteres hexadécimaux).

le troisième serait de stocker les images sur un serveur distant mais
le destinataire doit telecharger les images à chaque fois qu'il regarde
le mail :S pas terrible :)



donc voila. pour le code64 il me semble qu'il y a une tres bonne source sur ce site en parlant ...



vala vala :)

Si ma reponse vous convient, merci de l'accepter pour fermer le sujet