Première appli C# finie... portabilité??? dernieres questions [Résolu]

Signaler
Messages postés
35
Date d'inscription
mardi 7 décembre 2004
Statut
Membre
Dernière intervention
24 novembre 2005
-
Messages postés
35
Date d'inscription
mardi 7 décembre 2004
Statut
Membre
Dernière intervention
24 novembre 2005
-
Hello!
Ca y est j'ai fait ma premiere appli en c# sur mon poste!
(pour info, mon truc jusqu'a aujourd'hui c'était plus le web, asp + com en V6 , et plus recemment vb.net...)

bon, merci a tous pour avoir répondu à mes questions! ca m'a bien aidé quand j'étais bloqué...

Donc voila j'ai mon exe, ma dll avec une librairie de fonction (log erreur, ftp , mail, ...) et un appli.config qui prend tous mes parametres (connection base, chemin sur le disque, etc...)
Super...

1ere question : dans bin/release mon appli.config et renommé en
[nom_de_mon_appli].exe.config

je suis decu car en fait j'ai 2 traitements et donc 2 exe avec le meme fichier config... et donc quand les regroupent je vais avoir 2 fichiers .exe.config ... j'ai pas trouvé les options... comment je peux faire?

ET MA QUESTION :

Tout content je veux mettre mes sources sur un serveur de fichier, j'ai installé le framework, pris mes 2 exe, ma dll, mes 2 fichiers XML de config... et bam...ca marche pas:
messege d'erreur : exception non gérée blah blah , pas de JIT ,etc...

Il faut prendre le contenu du repertoire RELEASE ou il y a un autre mode de compilation?
mmmmmmmmaiiiisss....je fais quoi maintenant ;-)? je fais quoi maintenant ? je fais quoi maintenant ?

-------------------------------------
En apprentissage de C# !
Learn to Forget...
-------------------------------------

3 réponses

Messages postés
2368
Date d'inscription
mardi 17 avril 2001
Statut
Modérateur
Dernière intervention
26 décembre 2007
19
normalement le copier / Coller suffit.

COmme c'est sur un serveur , regarde si tu n'a pas des problème de droit par rapport a ce que fait cet assembly.

::|The S@ib|::
MVP C#.NET
Messages postés
35
Date d'inscription
mardi 7 décembre 2004
Statut
Membre
Dernière intervention
24 novembre 2005
1
je suis en train de monter le serveur... xp pro, framework...
tout le monde a tous les droits, je suis loggé en admin...
-------------------------------------
Learn to Forget...
-------------------------------------
Messages postés
35
Date d'inscription
mardi 7 décembre 2004
Statut
Membre
Dernière intervention
24 novembre 2005
1
Mouais j'y suis allé pas à pas
exe vide, etc...
ca doit etre le firewall de windows qui bloque le ftp...
Maintenant j'ai le périphérique n'est pas pret...
bah je vais trouver merci
-------------------------------------
Learn to Forget...
-------------------------------------