A l'aideuh ! probleme avec les sessions

Signaler
Messages postés
137
Date d'inscription
mardi 4 novembre 2003
Statut
Membre
Dernière intervention
22 août 2005
-
Messages postés
199
Date d'inscription
lundi 22 juillet 2002
Statut
Membre
Dernière intervention
14 juin 2006
-
je sais pas sic 'est mon hebergeur qui pose problème (free provisoirement) ou si je suis tout simplement pas malin, mais j'ia un problème avec les sessions...
je 'mexplique :
dans toutes les pages je 'nia aps oublié bien sur de mettre en première information session_start()... j'ia aussi voulu transmettre la variable $login sur toute smes pages tout simplement avec session_register($login)... mais, impossible de récupérer la variable !!!!! et pourtant je vois bien dans le dossier "sessions" de mon site qu'elle est présente dans chaque session... j'ia essayé de récupérer tout d'abord avec $login puis avec $_SESSION['login'] (je suis pas sur de ca), mais rien à faire... je désespere de trouver le probleme, j'avais pourtant fait attention à ce que la variable $login ne soit utilisé par une autre partie du code que si je 'nen ai aps besoin... j'ai changé le nomd e toutes mes variables pour essayer de résoudre le problème, mais rien à faire...
une dernière chose : toutes mes pages sont construites de la manière suivante, je sais pas si ca peut avoir un rapport quelconque, mais je le signale :
<? include('debut.inc'); ?>
corps de la page...
<? include('fin.inc'); ?>

... la fonction session_start() se situe bien sur dans "debut.inc".

aidez moi !!!

7 réponses

Messages postés
199
Date d'inscription
lundi 22 juillet 2002
Statut
Membre
Dernière intervention
14 juin 2006

slt,

Il faut créer un dossier sessions sur ton espace web pour que les sessions fonctionne chez FREE !!!!!!!

:(

8-) :-p

Trinita,

(Nous savons tous lire, alors passons un peu de temps sur les documentations. Pensons aux personnes qui les rédigent :big) ;) )
Messages postés
137
Date d'inscription
mardi 4 novembre 2003
Statut
Membre
Dernière intervention
22 août 2005

euh... t'es sur d'avoir tout lu ? le dossier "sessions" est bien créé, c''st comem ca que je vérifie si la fonction session_register() fonctionne bien. le probleme reste de récupérer cette variable
Messages postés
199
Date d'inscription
lundi 22 juillet 2002
Statut
Membre
Dernière intervention
14 juin 2006

Oups j'avais pas bien lu effectivement (dur dur aprem le déjeuner )

en fait je pense qu'il faut plutot faire :
$_SESSION["login"] = "T'as valeur"

apres un session_start();

8-) :-p

Trinita,

(Nous savons tous lire, alors passons un peu de temps sur les documentations. Pensons aux personnes qui les rédigent :big) ;) )
Messages postés
137
Date d'inscription
mardi 4 novembre 2003
Statut
Membre
Dernière intervention
22 août 2005

j'ai déjà essayé ^^ de plus ma valeur ej en veux pas la définir au début de la page
Messages postés
199
Date d'inscription
lundi 22 juillet 2002
Statut
Membre
Dernière intervention
14 juin 2006

est ce que la fonction session_start retourne TRUE quand tu la lances !!!
De plus fais moi voir un bout du code de debut.inc pour voir !!!

8-) :-p

Trinita,

(Nous savons tous lire, alors passons un peu de temps sur les documentations. Pensons aux personnes qui les rédigent :big) ;) )
Messages postés
137
Date d'inscription
mardi 4 novembre 2003
Statut
Membre
Dernière intervention
22 août 2005

elle retourne forcément TRUE pasque mon dossier "sessions" est repmpli avec la valeur des mariables !!!!!!
Messages postés
199
Date d'inscription
lundi 22 juillet 2002
Statut
Membre
Dernière intervention
14 juin 2006

la je commence à être collé !!!!!!!!!!!!!!!!!!

Fait voir le début du code des fois, on c'est jamais !

8-) :-p

Trinita,

(Nous savons tous lire, alors passons un peu de temps sur les documentations. Pensons aux personnes qui les rédigent :big) ;) )