Eclipse Java Termined code 1

cs_Taz1984 Messages postés 47 Date d'inscription lundi 20 juillet 2009 Statut Membre Dernière intervention 13 mars 2013 - 15 oct. 2011 à 17:51
cs_Taz1984 Messages postés 47 Date d'inscription lundi 20 juillet 2009 Statut Membre Dernière intervention 13 mars 2013 - 15 oct. 2011 à 20:14
Bonjour à tous,

J'ai un problème qui m’obsède depuis quelques temps avec eclipse.

Lorsque je lance des applications sur celle ci , j'ai un message d'erreur "JVM terminated exit code = 1"

Ci joint une capture d'écran , j'ai ce problème depuis que j'ai passé ma machine sur Windows Seven . j'ai cherché sur le net , il propose des solutions mais aucune n'a fonctionné.

Voici les données :
Java version 1.5.00_10
Eclipse SDK
Version: 3.2.1
Build id: M20060921-0945

Si quelqu'un a une idée je suis preneur :D !!!

Merci d'avance !!!
A voir également:

2 réponses

Utilisateur anonyme
15 oct. 2011 à 19:16
J'ai déjà eu ce genre de problèmes mais malheureusement je ne me souviens plus très bien de la manière dont j'ai résolu tout ça -_-"

Essaye de regarder ce qui suis, je ne garantie pas que ça a un rapport mais c'est susceptible généralement de poser des problèmes :

- JDK installé ?
- version d'Ecplise (x32 ou x64) identique à celle de Win 7 (x32 ou x64) ?
- essaye de désinstaller et de réinstaller proprement Eclipse voire Java.

Je suis presque sur que c'est parce que ton Eclipse est en 32 bits et ta version de 64 bits...Et oui, quand on dit que les programmes 64 bits tolèrent ceux en 32 bits, c'est pas tout à fait vrai. Voire faux -_-"


--
Pylouq
0
cs_Taz1984 Messages postés 47 Date d'inscription lundi 20 juillet 2009 Statut Membre Dernière intervention 13 mars 2013
15 oct. 2011 à 20:14
Bonsoir Pylouq,

Merci pour ta réponse , j'ai en fait cette erreur :
!SESSION 2011-09-20 09:19:44.608 -----------------------------------------------
eclipse.buildId=M20060921-0945
java.version=1.5.0_15
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=fr_FR
Command-line arguments: -os win32 -ws win32 -arch x86
*****************
*** System properties:
awt.toolkit=sun.awt.windows.WToolkit
eclipse.buildId=M20060921-0945
eclipse.commands=-os
win32
-ws
win32
-arch
x86
-launcher
D:\Projet Installation\eclipse\eclipseCIBLE\eclipseCIBLE\eclipse.exe
-name
Eclipse
-showsplash
600
-exitdata
760_8c
-vm
C:\Windows\system32\javaw.exe
eclipse.ee.install.verify=false
eclipse.product=org.eclipse.sdk.ide
eclipse.startTime=1318701944612
eclipse.vm=C:\Windows\system32\javaw.exe
eclipse.vmargs=-Xms256M
-Xmx512M
-XX:MaxPermSize=512M
-jar
D:\Projet Installation\eclipse\eclipseCIBLE\eclipseCIBLE\startup.jar
eof=eof
file.encoding=Cp1252
file.encoding.pkg=sun.io
file.separator=\
http.nonProxyHosts=localhost
http.proxyHost=proxy
http.proxyPort=3128
http.proxySet=true
https.nonProxyHosts=localhost
https.proxyHost=proxy
https.proxyPort=3128
https.proxySet=true
java.awt.graphicsenv=sun.awt.Win32GraphicsEnvironment
java.awt.printerjob=sun.awt.windows.WPrinterJob
java.class.path=D:\Projet Installation\eclipse\eclipseCIBLE\eclipseCIBLE\startup.jar
java.class.version=49.0
java.endorsed.dirs=C:\Program Files (x86)\Java\jre1.5.0_10\lib\endorsed
java.ext.dirs=C:\Program Files (x86)\Java\jre1.5.0_10\lib\ext
java.home=C:\Program Files (x86)\Java\jre1.5.0_10
java.io.tmpdir=C:\Users\A176695\AppData\Local\Temp\
java.library.path=C:\Windows\SysWOW64;.;C:\Windows\system32;C:\Windows;C:\Program Files (x86)\RSA SecurID Token Common;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Program Files\PuTTY;C:\Program Files (x86)\Java\jdk1.5.0_10\bin
java.runtime.name=Java(TM) 2 Runtime Environment, Standard Edition
java.runtime.version=1.5.0_10-b03
java.specification.name=Java Platform API Specification
java.specification.vendor=Sun Microsystems Inc.
java.specification.version=1.5
java.vendor=Sun Microsystems Inc.
java.vendor.url=http://java.sun.com/
java.vendor.url.bug=http://java.sun.com/cgi-bin/bugreport.cgi
java.version=1.5.0_10
java.vm.info=mixed mode
java.vm.name=Java HotSpot(TM) Client VM
java.vm.specification.name=Java Virtual Machine Specification
java.vm.specification.vendor=Sun Microsystems Inc.
java.vm.specification.version=1.0
java.vm.vendor=Sun Microsystems Inc.
java.vm.version=1.5.0_10-b03
line.separator=
****************************************


ma Jdk est installé, la version d'eclipse est x32 et windows 7 x64.
Malheureusement , je ne pense pas que mes plugins vont tourner sur une version x64 d’eclipse.

mise a part lancer une Vmware avec un system x32, es ce possible de faire tourner eclipse sur un x64 en tant que x32 !!!

Merci d'avance
0