Msvbvm60.dll\3

Signaler
Messages postés
252
Date d'inscription
mardi 3 juin 2003
Statut
Membre
Dernière intervention
29 juin 2013
-
Messages postés
252
Date d'inscription
mardi 3 juin 2003
Statut
Membre
Dernière intervention
29 juin 2013
-
Bonjour,
J'ai développé un module qui calcule les dimensions d'une image par l'intermédiaire de l'instruction GetDetailsOf.
Lorsque je distribue mon application, ce module plante sur certaines machines en produisant le message d'erreur 430 (La classe ne gère pas Automation...)
Je pense que cette erreur est liée au fait que mon module utilise comme référence "Visual Basic Runtime objects and procedures" liée au fichier msvbvm60.dll\3.
Mon SetUp, développé avec InnoSetUp, installe bien msvbvm60.dll mais je ne sais pas comment installer msvbvm60.dll\3!
Quelqu'un aurait-il une piste?
Jacques13

2 réponses

Messages postés
1
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
19 avril 2011

Bonjour,
J'ai eu parfois un problème similaire avec la plateforme visual basic qui plante affichant qu'elle ne trouve pas une librairie XXXX.dll\3 (je ne me souviens plus exactement quelle dll était en cause)

J'ai résolu le problème en cherchant cette dll dans la base des registres en renommant la valeur XXXX.dll\3 en XXXX.dll (j'ai supprimé la valeur \3) et cela marche parfaitement depuis.

ATTENTION : pas d'intervention dans la base des registres si vous ne maitrisez pas parfaitement la technique(sauvegarde de précaution SVP)

Beluga
Messages postés
252
Date d'inscription
mardi 3 juin 2003
Statut
Membre
Dernière intervention
29 juin 2013

Mais on ne peut pas faire cette manip à distance sur la machine de l'utilisateur...