Detection navigateur et messag alerte

Signaler
Messages postés
1
Date d'inscription
mardi 25 août 2009
Statut
Membre
Dernière intervention
1 septembre 2010
-
Messages postés
21
Date d'inscription
vendredi 3 janvier 2003
Statut
Membre
Dernière intervention
9 juin 2018
-
Bonsoir, voila mon site http://www.theworlddebating.com fonctionne mieux sur firefox, à cause de certaines balises div en position absolue. Bref je voudrais que à chaque fois qu'un internaute se connecte sur ma page d'accueil qu'un message d'alerte s'affiche du genre " attention vous n'utilisez pas firefox, mais vous pouvez continuer". J'avais deja trouvé ce script mais je l'ai perdu, et j'ai cherché longtemps sur le web la et je n'ai pas trouvé ce que je voulais. donc si vous pouviez m'aider ça serait génial, parce que mon site est terminé et c'est le dernier truc à faire!!! merci d'avance bonne soirée

3 réponses

Messages postés
647
Date d'inscription
samedi 30 décembre 2000
Statut
Membre
Dernière intervention
20 juillet 2012
7
Bonjour,

Évidemment, dans ces cas-ci, je me dois de vous faire la morale :

Faire un truc de ce genre ne fais absolument pas "professionel". Votre site passera pour le résultat d'un débutant qui n'a pas pris le temps de rendre compatible son site. La compatibilité est quelque chose d'essentiel dans le domaine.

Ensuite... pour ton cas... Tu peux trouver un très bon script (sinon le meilleur) de détection de navigateur (en anglais) ici : Quirksmode


JDMCreator
--------
Participez au nouveau projet : la wiki sur le javascript !
fr.jsinfo.wikia.com
Messages postés
3426
Date d'inscription
lundi 26 décembre 2005
Statut
Membre
Dernière intervention
14 janvier 2011
18
Bonjour,
...à cause de certaines balises div en position absolue...
c'est généralement ce qui pose le moins de problème et qui se résout en CSS pur

penses à tester la validité de ta page avec par exemple validator.w3.org/, pour le plus connu.

;O)
Messages postés
21
Date d'inscription
vendredi 3 janvier 2003
Statut
Membre
Dernière intervention
9 juin 2018

Enfin, quand on voit qu'il y a encore des gens sous ie6 et que les themes par défaut de monstre comem wordpress ne passe pas sur certaine version de navigateur, je pense qu'il faut agir...

Madvic