Calcul de moyenne particulier

Signaler
Messages postés
63
Date d'inscription
mercredi 16 juillet 2008
Statut
Membre
Dernière intervention
15 juillet 2009
-
Messages postés
2065
Date d'inscription
lundi 11 avril 2005
Statut
Membre
Dernière intervention
14 mars 2016
-
Bonjour,
Je suis actuellement en train de traiter des données et j'aimerais calculer des moyennes à l'aide de macros excel.
Je vous donne un exemple et je vous explique :

Colonne1 Colonne2 Colonne3
tronçon Valeur
1 2.44
5.15
8.24
4.28 6.24
2 1.25
0.59 0.75
3 2.59
3.58
9.24
12.57 7.58

Dans la colonne un j'ai plusieurs troncons. Dans la colonne 2 j'ai toutes les valeurs dans chaque troncon et dans la colonne 3 je voudrais les moyennes de chaque troncon.
Cela fait 2 jours que je suis sur ce code et je n'y arrive toujours pas. Si quelqu'un sait comment coder cela je veux bien qu'il m'en fasse part !

Merci d'avance !!
Vincent

5 réponses

Messages postés
63
Date d'inscription
mercredi 16 juillet 2008
Statut
Membre
Dernière intervention
15 juillet 2009

Je vous réenvoie la mise en forme car ca n'a pas rendu !


Colonne1  Colonne2   Colonne3
tronçon      Valeur
1                2.44
. .                 5.15
. .                 8.24
. .                 4.28       6.24
2                1.25
.  .                0.59       0.75
3                2.59
.                  3.58
.                  9.24
.                12.57       7.58

Merci d'avance !!
Vincent
Messages postés
2065
Date d'inscription
lundi 11 avril 2005
Statut
Membre
Dernière intervention
14 mars 2016
10
Bonjour,

Pourquoi la formule de base d'Excel "=Moyenne(plage)" ne convient pas ?

Amicalement,
Us.
Messages postés
63
Date d'inscription
mercredi 16 juillet 2008
Statut
Membre
Dernière intervention
15 juillet 2009

Bonjour,

Elle marche mais je voulais mettre ca dans une macro pour que ca soit automatique.

Merci
Messages postés
1402
Date d'inscription
mardi 1 mai 2007
Statut
Membre
Dernière intervention
7 octobre 2012
5
Bonjour,
facilites-toi la tache en remplissant les cases non renseignées de la colonne 1 par la valeur du trançon auquel elles appartiennent.
tronçon Valeur
1 2.44
1 5.15
1 8.24
1 4.28 6.24
2 1.25
2 0.59 0.75
3 2.59
3 3.58
3 9.24
3 12.57 7.58

Ainsi avec deux boucles imbriquées, et deux ou trois varaiables,tu pourras facilement y parvenir.

Je ne suis pas très fort en VBA et j' ai peur de dire des conneries, mais je te livre un schema directeur.

Tant que tu ne rencontres pas de cellule vide
Tronc=Cellule(LigneCourante,1)
Somm=Cellule(LigneCourante,2)
NbLignesDuTronc=1
Tant que Tronc=Cellule(LigneCourante,1)
LigneCourante=LigneCourante+1
Somm=Somm+Cellule(LigneCourante,2)
NbLignesDuTronc=NbLignesDuTronc+1
Loop
Cellule(LigneCourante,3)=Somm/NbLignesDuTronc
Loop


[] Ce qui va sans dire. va mieux en le disant.
Messages postés
2065
Date d'inscription
lundi 11 avril 2005
Statut
Membre
Dernière intervention
14 mars 2016
10
Bonjour,

Et si... tu utilises une formule tout même ?

A B C D E
1 1 2,44 1 2 3
2 1 5,15 5,0275 0,92 6,995
3 1 8,24
4 1 4,28
5 2 1,25
6 2 0,59
7 3 2,59
8 3 3,58
9 3 9,24
10 3 12,57

avec dans C1 :
=SOMME.SI($A:$A;C1;$B:$B)/NB.SI($A:$A;C1)

qu'on recopie dans D1, E1 , etc...

Amicalement,
Us.