Deploiement application vb.net

Picpic10
Messages postés
7
Date d'inscription
mardi 18 octobre 2005
Statut
Membre
Dernière intervention
12 mai 2009
- 11 mai 2009 à 15:43
cs_casy
Messages postés
7741
Date d'inscription
mercredi 1 septembre 2004
Statut
Membre
Dernière intervention
24 septembre 2014
- 12 mai 2009 à 20:56
Bonjour a tous,

Voici mon probleme, j'ai une application developper en VB.Net 2005, je l'ai compilé et déployé (ClickOnce installation) sur un serveur.
J'arrive a installer l'application sur plusieurs PC clients en lancant le fichier setup que j'ai mis sur le serveur (ex \\ServeurName\AppFolder\Setup.exe)
Le chemin de recherche des mises a jour sous ClickOnce est bon (ex \\ServeurName\AppFolder\NomDeMonApp.Application) et lorsque je deploi une nouvelle version de mon application, tous les PC se mettent bien a jour, aucun soucis jusque la.
Le souci est que je n'arrive pas a lancer cette application sur 1 PC! PC sous windows xp, remis a blank et sans antivirus ou firewall. L'application se télécharge correctement, s'install mais ne se lance pas. Si je lance l'application depuis le menu demarrer, la fenettre de recherche des mises a jour s'ouvre (il install bien la mise a jour si il y en a une disponible), a partir de la cette fenetre se ferme et l'application devrai se lancer mais elle ne se lance pas, aucun message d'erreur.

3 réponses

cs_casy
Messages postés
7741
Date d'inscription
mercredi 1 septembre 2004
Statut
Membre
Dernière intervention
24 septembre 2014
41
11 mai 2009 à 20:38
Vérifie que le framework est correctement installé sur cette machine.

---- Sevyc64  (alias Casy) ----<hr size="2" width="100%" /># LE PARTAGE EST NOTRE FORCE #    http://aide-office-vba.monforum.com/index.php
0
Picpic10
Messages postés
7
Date d'inscription
mardi 18 octobre 2005
Statut
Membre
Dernière intervention
12 mai 2009

12 mai 2009 à 14:03
Oui j'ai aussi pensé a ca, malheureusement il est bien installé, il est normalement installer en prerequis de l'application mais je l'ai desinstaller et retélécharcher depuis le site de microsoft.
Un truc qui me trotte dans la tete, peut etre un soucis avec Windows Installer? Je ne connais pas trop donc je ne sais pas vraiment comment Windows Installer fonctionne. Dans le passer j'ai eu un soucis avec ca, il etait corrompu et je ne pouvais plus installer ou desinstaller de programmes. J'avais a l'époque formaté la machine mais ce coup ci j'ai la contrainte de ne pas pouvoir formater.
Merci tout de meme pour ton aide.
0
cs_casy
Messages postés
7741
Date d'inscription
mercredi 1 septembre 2004
Statut
Membre
Dernière intervention
24 septembre 2014
41
12 mai 2009 à 20:56
Il te faut normalement au minimum la version 3.1 de windows installer. Tu peux le rajouter aux prerequis pour qu'il soit installer comme le framework.

Eventuellement tu peux aussi retrouver le package sur ton disque, normalmeent dans le dossier C:\Program Files\Microsoft SDKs\Windows\v6.0A\Bootstrapper\Packages\WindowsInstaller3_1, il s'agit du fichier WindowsInstaller-KB893803-v2-x86.exe

---- Sevyc64  (alias Casy) ----<hr size="2" width="100%" /># LE PARTAGE EST NOTRE FORCE #    http://aide-office-vba.monforum.com/index.php
0