Conflit avec mon fichier Web.config [Résolu]

Signaler
Messages postés
41
Date d'inscription
lundi 7 mars 2005
Statut
Membre
Dernière intervention
23 février 2009
-
Messages postés
41
Date d'inscription
lundi 7 mars 2005
Statut
Membre
Dernière intervention
23 février 2009
-
Bonjour,

Voila bien trois jours que je tourne en bourrique pour trouver mon problème. Il vient apparemment de mon fichier Web.config.Apparemment le fait d'ajouter mes httpHandlers m'empêche d'accéder au traçage et mes pages aspx

J'utilise:
   _ des pages .aspx
   _ des http handlers & http modules
   _ .Net Framework 2.0 (Visual studio 2008)
   _ le traçage ASP.Net

Mon problème:
J'arrive à accéder à mes pages .aspx et au traçage (trace.axd), si je désactive mes handlers
<?xml version= "1.0"?>
<configuration>
    <system.web>  
    <trace enabled="true" localOnly="false" traceMode="SortByTime" requestLimit="50"/>
        <compilation debug="true"/>
   
<!-- <httpHandlers>
     
     
     
     
     
    </httpHandlers>
    <httpModules>
     
    </httpModules>-->
  </system.web>
</configuration>

J'arrive à accéder à mes handlers, mais plus à mes pages .aspx, ou au traçage(page blanche) quand j'active mes handlers:
<?xml version ="1.0"?>
<configuration>
    <system.web>  
    <trace enabled="true" localOnly="false" traceMode="SortByTime" requestLimit="50"/>
        <compilation debug="true"/>
      <httpHandlers>
     
     
     
     
     
    </httpHandlers>
    <httpModules>
     
    </httpModules>
  </system.web>
</configuration>

Quelqu'un a t il déjà eu ce problème, ou alors a des pistes?
 

2 réponses

Messages postés
41
Date d'inscription
lundi 7 mars 2005
Statut
Membre
Dernière intervention
23 février 2009

Merci Seb_P pour ton aide, j'ai enfin trouvé mon problème. Rien dans mon fichier web.config.

Le problème venait de mon httpModule qui n'autorisait pas de requêtes autres que mes config.preset, start.preset, etc .... (Une erreur de ma part dans mon code à l'évènement: application_BeginRequest() de mon module.
Messages postés
40
Date d'inscription
mercredi 31 janvier 2007
Statut
Membre
Dernière intervention
23 février 2009

As-tu pensé a mettre <customErrors mode="Off"/>  dans la catégorie

    <system.web>
        <sessionStatetimeout="560"/>
        <customErrors mode="Off"/>
         [...]
        <httpHandlers>
        [...]
        </httpHandlers>
        [...]

Je ne sais pas si ca t'aidera mais cherche peut être par là ^^