Problème AJAX - IE7

Signaler
Messages postés
149
Date d'inscription
lundi 7 février 2005
Statut
Membre
Dernière intervention
6 février 2009
-
Messages postés
18
Date d'inscription
dimanche 31 octobre 2004
Statut
Membre
Dernière intervention
16 juin 2009
-
Salut à tous,

je reviens sur le sujet de ma visionneuse d'images AJAX sur laquelle javais déjà posé une question et ou je m'étais auto-répondu.

Comme c'était une appli pour mon back-office perso, je ne m'étais pas penché sur son fonctionnement pour Internet explorer. Et bien sur, en l'exécutant sur IE, qu-est ce que je constate? ca marche pas, normal.

Le problème est sur le rechargement AJAX, je m'explique.

Pour afficher une gallerie, on a deux étapes:
-On clique sur une catégorie mère qui affiche les sous-catégorie sans rechargement de page (ca ca marche)
-Ensuite, on clique sur une sous-catégorie pour, toujours sans rechargement, afficher la liste d'images (et là ca marche pas pour IE, pas de problème avec Firefox)

J'ai testé de faire un simple "Alert" sur onclick dans ma div rechargée et meme constat, ok pour FF et non pour IE. En plus le microsoft script debugger, c'est pas la joie.

Donc deux questions:
-Est-il impossible à Internet explorer d'appliquer du Javascript sur un élément rechargé en AJAX?
-Existe-t-il un meilleur debugger que MSD pour IE?

Merci à vous

2 réponses

Messages postés
149
Date d'inscription
lundi 7 février 2005
Statut
Membre
Dernière intervention
6 février 2009

Bon alors j'ai installé la debugbar pour IE qui m'a pas l'air trop crado, c'est toujours mieux que cet espèce de truc de microsoft.

La structure HTML après le premier rechargement m'a l'air correct, serait-ce donc réellement impossible d'effectuer ces rechargements en cascade sur IE?
Messages postés
18
Date d'inscription
dimanche 31 octobre 2004
Statut
Membre
Dernière intervention
16 juin 2009

Salut,


alors il te faut placer ton javascript sur la page mere, pas sur la page appelée.


c'est ce que je fais et ça marche