Références du projet VisualStudio disparues.. [Résolu]

Signaler
Messages postés
29
Date d'inscription
samedi 21 avril 2018
Statut
Membre
Dernière intervention
23 décembre 2018
-
Messages postés
15927
Date d'inscription
mardi 11 mars 2003
Statut
Contributeur
Dernière intervention
13 mai 2021
-


Bonjour,
Voilà le problème : toutes mes références ont subitement disparu. Je n'ai que des confusions avec des contrôles standard (label, textbox, timer, picturebox..)
VS me demande de tout remettre un par un.
Le nettoyage, le build et le rebuild génèrent des erreurs en surnombre.
N'y aurait-il pas une fonction automatique dans Visual Studio pour tout remettre automatiquement ?
Une idée ?

6 réponses

Messages postés
15927
Date d'inscription
mardi 11 mars 2003
Statut
Contributeur
Dernière intervention
13 mai 2021
544
Essaye de nettoyer la solution, puis tu fermes VS, éventuellement tu rebootes le pc.
Messages postés
15927
Date d'inscription
mardi 11 mars 2003
Statut
Contributeur
Dernière intervention
13 mai 2021
544
De rien pour les conseils.

Et les mystères de Windows étant impénétrables, je ne suis pas capable de te dire si la mise à jour a un lien.
Messages postés
15927
Date d'inscription
mardi 11 mars 2003
Statut
Contributeur
Dernière intervention
13 mai 2021
544
Bonjour

sur ta capture, on voit un certain nombre d'instruction VB6.
C'est donc la référence à Microsoft.VisualBasic que tu as enlevée.
C'est plutôt une bonne chose.

Mélanger VB.Net et VB6 n'est pas une bonne chose pour progresser en programmation objet, qui est le paradigme de .Net.

Je te conseille de remplacer ces instructions par celle correspondante en .Net.

Format => String.Format
MsgBox => MessageBox
Trim =>
"le texte ou la variable".Trim()


etc...
Messages postés
29
Date d'inscription
samedi 21 avril 2018
Statut
Membre
Dernière intervention
23 décembre 2018

Merci pour la réponse. Je vais voir
Messages postés
29
Date d'inscription
samedi 21 avril 2018
Statut
Membre
Dernière intervention
23 décembre 2018

Bon c'est une histoire de fous..
J'ajoute des références, et il m'en supprime d'autres.. là c'est plus de 700 erreurs générées.
Alors qu'avant, c'est à dire il y a une heure, tout fonctionnait parfaitement
Je suis dépité :-(
Messages postés
29
Date d'inscription
samedi 21 avril 2018
Statut
Membre
Dernière intervention
23 décembre 2018

Effectivement, ça a presque été résolu en rebootant. Il a quand même fallu refaire pas mal d'actions de restauration. Bref, et sur les dernières erreurs que j'ai eu du mal à solutionner, il m'avait changé le
System.Windows.Forms.Timer
en
Timers.Timer
.
Enfin.. voilà c'est résolu. Merci pour tes conseils ;-)
Je pense que la mise-à-jour de W10 dans la matinée a dû générer les problèmes que j'ai eus.