Slider menu d'images dynamiques (xml) avec liens

5/5 (33 avis)

Vue 44 436 fois - Téléchargée 12 748 fois

Description

C'est un slidermenu d'images avec un lien sur chaque image chargée dynamiquement à partir d'un fichier XML créé à partir du code http://www.flashkod.com/code.aspx?id=14182.
P.S. : je ne suis pas sponsorisée par la poste mais j'ai pris un lien d'exemple.

Conclusion :


Seul bug, après le click un décalage apparaît entre les images.
Si quelqu'un a une idée...

Codes Sources

A voir également

Ajouter un commentaire Commentaires
dreeck Messages postés 4 Date d'inscription vendredi 16 avril 2010 Statut Membre Dernière intervention 22 mai 2014
27 oct. 2010 à 15:05
Donc voici l'esxemple en clair car j'ai oublié le "multiplié"

this.onMouseMove = function() {
this.vitesseMenu = ((-(this._ymouse-286))/70) * mavariable;
}
dreeck Messages postés 4 Date d'inscription vendredi 16 avril 2010 Statut Membre Dernière intervention 22 mai 2014
27 oct. 2010 à 15:03
Bonjour, voilà j'ai un souci, j'ai créé une variable qui me permet d'arrêter le défilement des image, mais je ne sais pas ou la mettre.

j'ai pensé à la mettre ici mais ça ne fonctionne pas...

this.onMouseMove = function() {
this.vitesseMenu = ((-(this._ymouse-286))/70)[ici ma variable qui passe de 0 à 1 et inversement];
}


ça fait 2 jours que je suis dessus, si quelqu'un avait une solution pour moi, je lui en serais fort reconnaissant.

Merci d'avance

Cédric
_n3o_ Messages postés 4 Date d'inscription mardi 31 octobre 2006 Statut Membre Dernière intervention 21 octobre 2009
21 oct. 2009 à 10:52
Trés utile cette frise !
Neanmoins j'ai un soucis, je l'ai adaptée pour charger des images de 400px (Largeur) et supprimé la fonction de click.
Mais le probleme c'est que lors du defilement l'image de gauche disparait trop tot (et ce sur chaque image).
Et le slider ne "loop" pas ou au pire ne "stop" pas a la premiere et la derniere image.

Si quelqu'un peu m'aider a ajouter ces fonctions ca serai top ! !

Merci d'avance
Elvis502 Messages postés 1 Date d'inscription lundi 26 mai 2008 Statut Membre Dernière intervention 11 décembre 2008
11 déc. 2008 à 12:31
Bonjour !

super cette frise !

Je l'ai personnaliser tout marche nickel par contre ne n'arrive pas
a l'intrégré dans une autre animation flash.

C'est possible ?

si oui, comment svp ?
20156 Messages postés 79 Date d'inscription samedi 12 novembre 2005 Statut Membre Dernière intervention 3 mars 2010
5 déc. 2008 à 17:55
Pour le blanc de chargement à gauche, il faut déplacer le movieclip sur l'axe x:-40
et c'est ok !
;)
Afficher les 33 commentaires

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes et codes sources.

Le fait d'être membre vous permet d'avoir des options supplémentaires.