Pb ASP2 avec IIS5.0 [Résolu]

Signaler
Messages postés
58
Date d'inscription
mercredi 15 décembre 2004
Statut
Membre
Dernière intervention
20 décembre 2010
-
Messages postés
58
Date d'inscription
mercredi 15 décembre 2004
Statut
Membre
Dernière intervention
20 décembre 2010
-
Bonjour,

je developpe un site web sous vb2005, mais lorsque je publie le site sur mon serveur iis 5.0 de ma machine de dév, cela me donne le problème suivant alors quand simulation dans vb cela fonctionne !! Est ce parce que je dév en vb2005 donc avec ASP2 et que le serveur utilise ASP1.1?? alors comment une appli developpée en ASP2 pourai etre publiée sur un serveur IIS5.0???
merci pour vos réponse ..!

Erreur de configuration
Description : Une erreur s'est produite lors du traitement d'un fichier de configuration requis pour répondre à cette demande. Veuillez consulter ci-dessous les détails relatifs à l'erreur en question, puis modifier votre fichier de configuration de manière appropriée.

Message d'erreur de l'analyseur: Section de configuration 'connectionStrings' non reconnue

Erreur source:

Ligne 10 : <configuration>
Ligne 11 : 
Ligne 12 :  	<connectionStrings/>
Ligne 13 : 	<system.web>
Ligne 14 : 		<!--



Fichier source : C:\Projet VB Net 2005\WebTest1\PrecompiledWeb\WebTest1\web.config    Ligne : 12

<hr width="100%" color="silver" size="1" />Informations sur la version : Version Microsoft .NET Framework :1.1.4322.2032; Version ASP.NET :1.1.4322.2032 <!--
[ConfigurationException]: Section de configuration 'connectionStrings' non reconnue (C:\Projet VB Net 2005\WebTest1\PrecompiledWeb\WebTest1\web.config line 12)
at System.Web.Configuration.HttpConfigurationSystem.CacheLookup(String vpath)
at System.Web.Configuration.HttpConfigurationSystem.ComposeConfig(String reqPath, IHttpMapPath configmap)
at System.Web.HttpContext.GetAppConfig(String name)
at System.Web.HttpContext.GetAppLKGConfig(String name)
-->

3 réponses

Messages postés
58
Date d'inscription
mercredi 15 décembre 2004
Statut
Membre
Dernière intervention
20 décembre 2010

salut..
En faite j'ai réussi à faire tourner un site développé en vb2005 sur mon serveur IIS de mon PC de développement! Pour cela j'ai changé de type de projet ! Au lieu de créer un projet fichier j'ai créé un projet http (à la création d'un nouveau projet web) et avec ca cela fonctionne !
Merci pour vos réponse (en passant FrameWork 2.0 est installé sur ma machine !)
Messages postés
1642
Date d'inscription
samedi 6 novembre 2004
Statut
Modérateur
Dernière intervention
28 avril 2011
3
Salut,

Il faut évidemment installer le framework 2.0 sur ton serveur pour faire tourner ASP.NET 2.0 !
Après l'avoir installé, exécute "C:\Windows\Microsoft.NET\Framework\v2.0.50727\aspnet_regiis.exe /i" (adapte le chemin à ton cas...) pour enregistrer ASP.NET auprès de IIS, et normalement c'est bon .

Bonne journée,
A++

<hr width="100%" size="2" />Nurgle (Antoine) - MSP
Messages postés
410
Date d'inscription
dimanche 1 février 2004
Statut
Membre
Dernière intervention
8 mai 2010

Bonjour,
Je crois bien qu'en plus il faut déclarer sur le serveur, dans les propriétés du site, onglet ASP.NET je crois, qu'il s'agit de asp.net 2.0
@+Gilles