[débutant] Applet qui ne se charge pas

Résolu
Messages postés
10
Date d'inscription
mercredi 25 janvier 2006
Statut
Membre
Dernière intervention
25 septembre 2006
-
Messages postés
108
Date d'inscription
samedi 31 juillet 2004
Statut
Membre
Dernière intervention
12 septembre 2009
-
Salut a tous,

je me met au java et je suis en train de faire les TD disponible ici:
[url]http://www.developpez.org/club/bkostrzewa/td-applets/applet1.html/url

J'ai fait exactement ce qui est dit, mais ca ne marche pas chez moi (l'exemple sur la page marche bien mais quand je le fait chez moi l'applet met chargement de Applet Jave... et rien ne se passe).

J'ai les erreurs suivantes dans ma console JAVA:

java.lang.UnsupportedClassVersionError: bonjour (Unsupported major.minor version 49.0)

    at java.lang.ClassLoader.defineClass0(Native Method)

    at java.lang.ClassLoader.defineClass(Unknown Source)

    at java.security.SecureClassLoader.defineClass(Unknown Source)

    at sun.applet.AppletClassLoader.findClass(Unknown Source)

    at sun.plugin.security.PluginClassLoader.findClass(Unknown Source)

    at java.lang.ClassLoader.loadClass(Unknown Source)

    at sun.applet.AppletClassLoader.loadClass(Unknown Source)

    at java.lang.ClassLoader.loadClass(Unknown Source)

    at sun.applet.AppletClassLoader.loadCode(Unknown Source)

    at sun.applet.AppletPanel.createApplet(Unknown Source)

    at sun.plugin.AppletViewer.createApplet(Unknown Source)

    at sun.applet.AppletPanel.runLoader(Unknown Source)

    at sun.applet.AppletPanel.run(Unknown Source)

    at java.lang.Thread.run(Unknown Source)


Savez vous pourquoi j'ai cette erreur?

4 réponses

Messages postés
108
Date d'inscription
samedi 31 juillet 2004
Statut
Membre
Dernière intervention
12 septembre 2009
3
installe Jdk update 8 c'est la version la plus recente
Messages postés
108
Date d'inscription
samedi 31 juillet 2004
Statut
Membre
Dernière intervention
12 septembre 2009
3
Quelle est la version de ta JVM
tape :
java -version
dans ta console
Messages postés
10
Date d'inscription
mercredi 25 janvier 2006
Statut
Membre
Dernière intervention
25 septembre 2006

java.version = 1.3.1_18
Messages postés
108
Date d'inscription
samedi 31 juillet 2004
Statut
Membre
Dernière intervention
12 septembre 2009
3
oh la tres aicienne version
ton applete utilise des packages d'une version plus recente
regarde l'erreur produite:
java.lang.UnsupportedClassVersionError

installe la nouvelle version du J2SE c'est la 1.5.0.08 telechargable ici
http://java.sun.com/javase/downloads/index.jsp
et relance